app-text/libqxp: Add missing test DEPEND
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 28 May 2020 17:17:40 +0000 (19:17 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 28 May 2020 17:18:08 +0000 (19:18 +0200)
Closes: https://bugs.gentoo.org/718568
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/libqxp/libqxp-0.0.2.ebuild

index ed370e59bacc67b5c704568d9b8ced47486d55b2..b8a7b7ad69f90ab0cf94d74093eef22c908276ac 100644 (file)
@@ -14,11 +14,12 @@ IUSE="debug doc test tools"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
-       dev-libs/librevenge
        dev-libs/icu:=
+       dev-libs/librevenge
 "
 DEPEND="${RDEPEND}
        dev-libs/boost
+       test? ( dev-util/cppunit )
 "
 BDEPEND="
        virtual/pkgconfig
@@ -38,5 +39,5 @@ src_configure() {
 
 src_install() {
        default
-       find "${D}" -name '*.la' -delete || die
+       find "${D}" -name '*.la' -type f -delete || die
 }