tweaks for welp to test
authorDoug Goldstein <cardoe@gentoo.org>
Wed, 11 Apr 2007 19:56:56 +0000 (19:56 +0000)
committerDoug Goldstein <cardoe@gentoo.org>
Wed, 11 Apr 2007 19:56:56 +0000 (19:56 +0000)
Package-Manager: portage-2.1.2.3

sys-apps/hal/files/0.5.9/05_freebsd_partutil_make_fix.patch
sys-apps/hal/files/0.5.9/07_malloc_h_for_stdlib_h.patch

index c11d24de47dbc71c5eabfbf56f599a1ededa9495..a3f5a7eee6c43655cbacad5e466bfce2e0d2c770 100644 (file)
@@ -1,24 +1,20 @@
 Index: b/partutil/Makefile.am
 ===================================================================
---- a/partutil/Makefile.am     2007-04-11 12:15:39.000000000 -0400
-+++ b/partutil/Makefile.am     2007-04-11 12:23:05.000000000 -0400
-@@ -1,12 +1,8 @@
+--- a/partutil/Makefile.am     2007-04-11 15:50:44.000000000 -0400
++++ b/partutil/Makefile.am     2007-04-11 15:51:14.000000000 -0400
+@@ -1,13 +1,8 @@
 -if HALD_COMPILE_SOLARIS 
 -# do nothing
 -else if HALD_COMPILE_FREEBSD
 -# do nothing
 -else 
--
- INCLUDES = @GLIB_CFLAGS@
 +if HALD_COMPILE_LINUX
- noinst_LTLIBRARIES = libpartutil.la
-+endif
++noinst_LTLIBRARIES = libpartutil.la
  
- libpartutil_la_SOURCES = partutil.h partutil.c ../hald/logger.c
+ INCLUDES = @GLIB_CFLAGS@
  
-@@ -14,4 +10,3 @@
+-noinst_LTLIBRARIES = libpartutil.la
+-
+ libpartutil_la_SOURCES = partutil.h partutil.c ../hald/logger.c
  
- clean-local :
-       rm -f *~
--endif
+ libpartutil_la_LIBADD = @GLIB_LIBS@ @PARTED_LIBS@
index 2e3f4efeb9887574cd3a5e4db61bca6d298f551f..de1c539d126340d42f2e2259580de5e85795e15f 100644 (file)
@@ -1,7 +1,7 @@
 Index: b/hald/create_cache.c
 ===================================================================
---- a/hald/create_cache.c      2007-03-07 16:55:02.000000000 -0500
-+++ b/hald/create_cache.c      2007-04-11 12:58:44.000000000 -0400
+--- a/hald/create_cache.c      2007-04-11 14:19:13.000000000 -0400
++++ b/hald/create_cache.c      2007-04-11 15:16:14.000000000 -0400
 @@ -34,8 +34,8 @@
  #include <unistd.h>
  #include <string.h>
@@ -14,8 +14,8 @@ Index: b/hald/create_cache.c
  #include <getopt.h>
 Index: b/hald/hald.c
 ===================================================================
---- a/hald/hald.c      2007-04-06 19:25:20.000000000 -0400
-+++ b/hald/hald.c      2007-04-11 12:59:03.000000000 -0400
+--- a/hald/hald.c      2007-04-11 14:19:13.000000000 -0400
++++ b/hald/hald.c      2007-04-11 15:16:14.000000000 -0400
 @@ -43,7 +43,6 @@
  #include <syslog.h>
  #include <sys/time.h>
@@ -24,3 +24,16 @@ Index: b/hald/hald.c
  #include <dbus/dbus.h>
  #include <dbus/dbus-glib.h>
  #include <dbus/dbus-glib-lowlevel.h>
+Index: b/hald/cache_test.c
+===================================================================
+--- a/hald/cache_test.c        2007-04-11 15:17:04.000000000 -0400
++++ b/hald/cache_test.c        2007-04-11 15:17:32.000000000 -0400
+@@ -34,7 +34,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <dirent.h>
+ #include <errno.h>
+ #include <expat.h>