dev-python/carbon: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 14:10:03 +0000 (15:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 14:49:58 +0000 (15:49 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/carbon/Manifest
dev-python/carbon/carbon-1.1.3-r1.ebuild [deleted file]

index d1f93f5e77a475f7c8df6074b2234e6f9d5dab2b..02d3976e9e4e84fd14c63187b5c94a90e48da58c 100644 (file)
@@ -1,2 +1 @@
-DIST carbon-1.1.3.tar.gz 68824 BLAKE2B b5e532fa0d0d8dc8ab8c3c555dea6bb3b918cd5b516ea4c754f9b3cd37230f54b63d202cfead9ec4242ebf78031c2671050354dccccde2980c4101b9699b1393 SHA512 0cfa9260484de147660110b7d2cc7e41bcbd7751c80bd5c557534b2a52c2183fdba94d40f8654fe54f593b2ab34581b2480e96c8a6dde4d47de783153a2cbe65
 DIST carbon-1.1.5.tar.gz 72365 BLAKE2B 304e515fd3cae806e141d0a76983d13967885a7e57c310d86c0c83560aa306a573676fb0135fceccf14cc7ed42d8a9dcb7869ab0d6ac3b2fc00c2fb088011873 SHA512 1b3a0a0d4005e2ec8d5bca062b41f0e18329c1bc4d3a4b3eca5e8f7c94c20387281392eefceaca90294e51860eabecca242c487068433119f1f249f8659ed560
diff --git a/dev-python/carbon/carbon-1.1.3-r1.ebuild b/dev-python/carbon/carbon-1.1.3-r1.ebuild
deleted file mode 100644 (file)
index 9bad635..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Backend data caching and persistence daemon for Graphite"
-HOMEPAGE="https://graphiteapp.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86 ~x64-solaris"
-
-# whisper appears to have been missed from listing in install_requires in setup.py
-RDEPEND="
-       dev-python/twisted[${PYTHON_USEDEP}]
-       dev-python/cachetools[${PYTHON_USEDEP}]
-       dev-python/txAMQP[${PYTHON_USEDEP}]
-       dev-python/urllib3[${PYTHON_USEDEP}]
-       =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # bug #661340, excerpt from upstream, next release should have it
-       sed -i -e "s/'r+'/'rb+'/" lib/carbon/log.py || die
-
-       # Do not install the configuration and data files. We install them
-       # somewhere sensible by hand.
-       sed -i -e '/data_files=install_files,/d' setup.py || die
-       # We want FHS-style paths instead of /opt/graphite
-       export GRAPHITE_NO_PREFIX=yes
-       distutils-r1_python_prepare_all
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       insinto /etc/carbon
-       doins conf/*
-
-       keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
-
-       newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
-       newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
-       newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
-
-       newconfd "${FILESDIR}"/carbon.confd carbon-cache
-       newconfd "${FILESDIR}"/carbon.confd carbon-relay
-       newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
-}
-
-pkg_postinst() {
-       einfo 'This ebuild installs carbon into FHS-style paths.'
-       einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
-       einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
-       einfo '(see /etc/carbon/carbon.conf.example).'
-       einfo ' '
-       einfo 'OpenRC init script supports multiple instances !'
-       einfo 'Example to run an instance b of carbon-cache :'
-       einfo '    ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
-       einfo '    cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
-}