dev-python/xonsh: Drop old
authorPacho Ramos <pacho@gentoo.org>
Tue, 26 Jun 2018 18:32:47 +0000 (20:32 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 26 Jun 2018 18:46:10 +0000 (20:46 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/xonsh/Manifest
dev-python/xonsh/files/xonsh-0.4.4-destdir.patch [deleted file]
dev-python/xonsh/xonsh-0.2.6.ebuild [deleted file]
dev-python/xonsh/xonsh-0.4.4.ebuild [deleted file]

index 961743b6b6d5836dfd0c94ae985706f8306b5cf7..6537ddfd9564fddb791582e83a497bb1044cda24 100644 (file)
@@ -1,3 +1 @@
-DIST xonsh-0.2.6.tar.gz 170842 BLAKE2B 2fc02ce5e4cfaf1f3b602658ad313e576881163e1255863ab0a714a0248046e632fa57e67ac2b9cd403d63f6202aaccf0edcf49f25ac65d385c3cef06576f108 SHA512 43b034987323b832d052974f02a52ffd492ae4f0fbf6a0a035329000e393c9c9466ee0275cf678db5581e84e627d59bac015ad6131f35bdfbc1374bf4db20977
-DIST xonsh-0.4.4.tar.gz 543801 BLAKE2B c00358688d9b05ebf9326fdb6536a927d86ee9d5d2520237c59cacfbcf41819028a675d198cf4896b870e956592c24b667aaa9075c41f36f707c0d4526a053d5 SHA512 2cb6b045010b51d1a846625821bb6a8e415cc01f0e623f1ab7efb02ae0debaf9dab1e0bca0d27dd00a320bb1f5d9d001833ecf3a917562b683a7c59a51b8aff0
 DIST xonsh-0.4.7.tar.gz 545249 BLAKE2B e7207274cccbd96a32942dad7e5b0e44c4a053c52a0f4e06bc789d86414d678192ce885e3d2cccf2c4f4d208567a2beb1319ffd01e150b5a1a953cb82ca75598 SHA512 133a493b1245048e4b8a51f01f0629283736753a7636d8bb0c123b623122b285fed9ba415972e5f44dbb9a1439a83858da50a9b01ebe6bb11e4e390708e08c9f
diff --git a/dev-python/xonsh/files/xonsh-0.4.4-destdir.patch b/dev-python/xonsh/files/xonsh-0.4.4-destdir.patch
deleted file mode 100644 (file)
index 63d7e86..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
- setup.py | 3 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/setup.py b/setup.py
-index 679f984..6de421e 100755
---- a/setup.py
-+++ b/setup.py
-@@ -167,6 +167,8 @@ class xinstall(install):
-         # install Jupyter hook
-         root = self.root if self.root else None
-         prefix = self.prefix if self.prefix else None
-+        destdir = os.environ["ED"]
-+        prefix = destdir + prefix
-         try:
-             install_jupyter_hook(prefix=prefix, root=root)
-         except Exception:
diff --git a/dev-python/xonsh/xonsh-0.2.6.ebuild b/dev-python/xonsh/xonsh-0.2.6.ebuild
deleted file mode 100644 (file)
index 661d625..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="An exotic, usable shell"
-HOMEPAGE="
-       https://github.com/scopatz/xonsh
-       https://pypi.org/project/xonsh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       dev-python/ply[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       sed \
-               -e "/install_kernel_spec/s:prefix=None:prefix=u\"${ED}/usr\":g" \
-               -i setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests --verbose || die
-}
-
-pkg_postinst() {
-       optfeature "Jupyter kernel support" dev-python/jupyter
-       optfeature "Alternative to readline backend" dev-python/prompt_toolkit
-}
diff --git a/dev-python/xonsh/xonsh-0.4.4.ebuild b/dev-python/xonsh/xonsh-0.4.4.ebuild
deleted file mode 100644 (file)
index 7c361d8..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="An exotic, usable shell"
-HOMEPAGE="
-       https://github.com/scopatz/xonsh
-       https://pypi.org/project/xonsh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       dev-python/ply[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-destdir.patch
-)
-
-python_test() {
-       nosetests --verbose || die
-}
-
-src_install() {
-       export "${ED}"
-       distutils-r1_src_install
-}
-
-pkg_postinst() {
-       optfeature "Jupyter kernel support" dev-python/jupyter
-       optfeature "Alternative to readline backend" dev-python/prompt_toolkit
-}