net-libs/libsoup: bump to 2.66.2, fix vala:0.46 compat
authorMart Raudsepp <leio@gentoo.org>
Fri, 23 Aug 2019 19:19:17 +0000 (22:19 +0300)
committerMart Raudsepp <leio@gentoo.org>
Fri, 23 Aug 2019 19:32:20 +0000 (22:32 +0300)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-libs/libsoup/Manifest
net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch [new file with mode: 0644]
net-libs/libsoup/files/disable-apache-tests.patch [new file with mode: 0644]
net-libs/libsoup/libsoup-2.66.2.ebuild [new file with mode: 0644]

index f7aa4020665abded9b07ba570500662e551b63c4..f180d4e59e48727850efa22a8698a6076df4e917 100644 (file)
@@ -1,3 +1,4 @@
 DIST libsoup-2.58.2.tar.xz 1815256 BLAKE2B 23c6e40f91a2dca13fcabe4fa3af7311874cbe06962c6cdc93d8d8d0a998d29cff9e7ce61190541b6114b4996d758b7c469b0354a6012856667e9541a78177cb SHA512 85af6fac87343bdd22312518402144d33916225f60d6fa158efdd84f7ee7ed1f9895989b3558f711c9aedc93cff35a4114ad79d6d2aa19c54cb326f162a4c7de
 DIST libsoup-2.62.3.tar.xz 1851780 BLAKE2B e3a3518f485d4ab1fe133f5b382d32e4b949e720005c4fdbbe963ba68030d5fcfb11deb5103843f47f221b540e96c5d5ea0f7c52f898617dca37d8df9faec669 SHA512 88354728b1da10288472c7380f166263b64d979df3e6e70ebdbc7b61f3c8eb1dc1205d5b1ead16243c6d304940a4dd4e3a9f3b2ce3e1422a1c5032220b16c73b
 DIST libsoup-2.64.2.tar.xz 1793440 BLAKE2B 77a41ad62e0e419711cb26f510b6c0ca09c0430300f72144a0d0563a24e24639d1ca430784051b8de279623193a273510d5c95de6edb4a54a3aee0bd7903d9cd SHA512 c001495be4e1eafd169b904431b22e961b52f5a3202f2e75b0657281cbfd91153148765bd95378bba3e85a66d7eaca428750641f20c07ca3232d1f9bdabdc90f
+DIST libsoup-2.66.2.tar.xz 1446024 BLAKE2B 2953b91e3bf28b80189a87ecff3a9d103d57bb090f62121dc441e9bfa65750b67f2ab4f50e7a7a0cf5691b79139ae84de5aeaff69e7505b5c2fdd3f375536724 SHA512 1df443470239f23d22301e37e36f3d34963352ee0122f317cd15b19d90115831091bddcee27bc6f0d4994adcf4e5bd9c0395de2bd7f39ae305ba0edea7789092
diff --git a/net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch b/net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch
new file mode 100644 (file)
index 0000000..ce0e1dc
--- /dev/null
@@ -0,0 +1,26 @@
+From 1c6f47df99cc5b2efe3d629c71c5d85a7871689c Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Tue, 28 May 2019 09:08:35 +0200
+Subject: [PATCH] gir: soup_auth_new is not a constructor
+
+---
+ libsoup/Soup-2.4.metadata | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/libsoup/Soup-2.4.metadata b/libsoup/Soup-2.4.metadata
+index c0056ec8..1f107eda 100644
+--- a/libsoup/Soup-2.4.metadata
++++ b/libsoup/Soup-2.4.metadata
+@@ -18,6 +18,9 @@ ProxyResolver deprecated_since="2.28" replacement="ProxyURIResolver"
+ // Report upstream
+ add_* skip=false type="unowned GLib.TimeoutSource"
++Auth
++      // Factory method
++      .new symbol_type="function"
+ AuthDomain
+       .accepts#method name="accepts_authorization"
+ AuthDomainBasic.new skip=false
+-- 
+2.20.1
+
diff --git a/net-libs/libsoup/files/disable-apache-tests.patch b/net-libs/libsoup/files/disable-apache-tests.patch
new file mode 100644 (file)
index 0000000..e7d306b
--- /dev/null
@@ -0,0 +1,33 @@
+From 6c9bbf0d91688e831f8f19232e18619bfc57e12e Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Fri, 23 Aug 2019 21:11:57 +0300
+Subject: [PATCH] meson: Force disable apache/php using tests for now
+
+We had them disabled in autotools with a sed. Keep them disabled for now
+in meson port as well. Should be revisited at some point.
+---
+ meson.build | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 89837c15..f0e34cb0 100644
+--- a/meson.build
++++ b/meson.build
+@@ -162,12 +162,9 @@ endif
+ #
+ # The summary is that for the configuration parsing we will use the apachectl,
+ # but for running the tests we will use the httpd binary.
+-apachectl = find_program('apachectl', '/sbin/apachectl', '/usr/sbin/apachectl', required : false)
++apachectl = disabler()
+ # This abomination is a result of https://github.com/mesonbuild/meson/issues/1576
+-apache_httpd2 = find_program('httpd2', 'httpd', 'apache2', 'apache',
+-             '/sbin/httpd2', '/sbin/httpd', '/sbin/apache2', '/sbin/apache',
+-             '/usr/sbin/httpd2', '/usr/sbin/httpd', '/usr/sbin/apache2', '/usr/sbin/apache',
+-             required : false)
++apache_httpd2 = disabler()
+ have_apache=false
+ apache_httpd2_version = ''
+ if apache_httpd2.found() and apachectl.found()
+-- 
+2.20.1
+
diff --git a/net-libs/libsoup/libsoup-2.66.2.ebuild b/net-libs/libsoup/libsoup-2.66.2.ebuild
new file mode 100644 (file)
index 0000000..5796336
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson multilib-minimal vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+
+IUSE="gssapi gtk-doc +introspection samba ssl test +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DEPEND="
+       >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
+       >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+       gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+       samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+       >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.20
+               app-text/docbook-xml-dtd:4.1.2 )
+       >=sys-devel/gettext-0.19.8
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       vala? ( $(vala_depend) )
+"
+#      test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+#              apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+#              apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+#              dev-lang/php[apache2,xmlrpc]
+#              net-misc/curl
+#              net-libs/glib-networking[ssl])"
+
+PATCHES=(
+       # Disable apache tests until they are usable on Gentoo, bug #326957
+       "${FILESDIR}"/disable-apache-tests.patch
+       # Fix libsoup-2.4.vapi to be compatible with vala:0.46 and onwards. Included in 2.67.2
+       "${FILESDIR}"/${PV}-vala-0.46-compat.patch
+)
+
+src_prepare() {
+       use vala && vala_src_prepare
+       xdg_src_prepare
+}
+
+src_configure() {
+       # FIXME: we need addpredict to workaround bug #324779 until
+       # root cause (bug #249496) is solved
+       # But necessary while apache tests are disabled
+       #addpredict /usr/share/snmp/mibs/.index
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local emesonargs=(
+               $(meson_use gssapi)
+               -Dkrb5_config="${CHOST}-krb5-config"
+               $(meson_use samba ntlm)
+               -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+               -Dtls_check=false # disables check, we still rdep on glib-networking
+               -Dgnome=false
+               -Dintrospection=$(multilib_native_usex introspection true false)
+               -Dvapi=$(multilib_native_usex vala true false)
+               -Ddoc=$(multilib_native_usex gtk-doc true false)
+               $(meson_use test tests)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}