Bump to 1.8
authorDaniel Gryniewicz <dang@gentoo.org>
Mon, 19 Feb 2007 22:12:55 +0000 (22:12 +0000)
committerDaniel Gryniewicz <dang@gentoo.org>
Mon, 19 Feb 2007 22:12:55 +0000 (22:12 +0000)
 o Made it easier to include example code in the source code comment blocks.
   "|[ ... ]|" can be used to delineate example code (it just gets converted
   to "<informalexample><programlisting>"), and most of the text in example
   code is left as it is. The only thing that is still expanded is
   '#' to allow links to a symbol's documentation, e.g. '#GtkWidget'.
 o Made the field widths wider for the HTML output, so it looks a bit nicer.
 o Added a '--rebuild-sections' option to gtkdoc-scan to automatically rebuild
   the MODULE-sections.txt file. This only works if all the header files are
   organized neatly and functions don't need rearranging in the docs.
 o Added a '--rebuild-types' option to gtkdoc-scan to automatically rebuild
   the MODULE.types file, so you don't need to add new types manually.
 o Leave CDATA sections as they are, in the extra XML content files and within
   source code comment blocks.
 o Allow the section id and #include's to be set within the "SECTION:" comment
   block, using "@Section_ID:xxx" and "@Include:".
 o Added "--default-includes" option to specify the default #include's (for
   people who are using --rebuild-sections and so can't specify it in
   MODULE-sections.txt).
 o Added a '--query-child-properties' argument to help document child
   properties of arbitrary GObjects (used by things like canvas widgets).
 o Fixed documentation of signals of interfaces.

Package-Manager: portage-2.1.2-r9

dev-util/gtk-doc/ChangeLog
dev-util/gtk-doc/files/digest-gtk-doc-1.8 [new file with mode: 0644]
dev-util/gtk-doc/gtk-doc-1.8.ebuild [new file with mode: 0644]

index a4f05b72cc11f5fff7e213c529177ffaa00aab03..f2790baf4b4d9c166b3f79c111424dc6e2849fb7 100644 (file)
@@ -1,6 +1,32 @@
 # ChangeLog for dev-util/gtk-doc
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.74 2006/12/21 02:35:55 uberlord Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.75 2007/02/19 22:12:55 dang Exp $
+
+*gtk-doc-1.8 (19 Feb 2007)
+
+  19 Feb 2007; Daniel Gryniewicz <dang@gentoo.org> +gtk-doc-1.8.ebuild:
+  Bump to 1.8
+   o Made it easier to include example code in the source code comment blocks.
+     "|[ ... ]|" can be used to delineate example code (it just gets converted
+     to "<informalexample><programlisting>"), and most of the text in example
+     code is left as it is. The only thing that is still expanded is
+     '#' to allow links to a symbol's documentation, e.g. '#GtkWidget'.
+   o Made the field widths wider for the HTML output, so it looks a bit nicer.
+   o Added a '--rebuild-sections' option to gtkdoc-scan to automatically rebuild
+     the MODULE-sections.txt file. This only works if all the header files are
+     organized neatly and functions don't need rearranging in the docs.
+   o Added a '--rebuild-types' option to gtkdoc-scan to automatically rebuild
+     the MODULE.types file, so you don't need to add new types manually.
+   o Leave CDATA sections as they are, in the extra XML content files and within
+     source code comment blocks.
+   o Allow the section id and #include's to be set within the "SECTION:" comment
+     block, using "@Section_ID:xxx" and "@Include:".
+   o Added "--default-includes" option to specify the default #include's (for
+     people who are using --rebuild-sections and so can't specify it in
+     MODULE-sections.txt).
+   o Added a '--query-child-properties' argument to help document child
+     properties of arbitrary GObjects (used by things like canvas widgets).
+   o Fixed documentation of signals of interfaces.
 
   21 Dec 2006; Roy Marples <uberlord@gentoo.org> gtk-doc-1.7.ebuild:
   Added ~sparc-fbsd keyword.
diff --git a/dev-util/gtk-doc/files/digest-gtk-doc-1.8 b/dev-util/gtk-doc/files/digest-gtk-doc-1.8
new file mode 100644 (file)
index 0000000..8aae6f8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e61595df21431db28c83fe4c7d4a4fa8 gtk-doc-1.8.tar.bz2 186203
+RMD160 fbb3e36e3cdf9904439262b2bafab86017691984 gtk-doc-1.8.tar.bz2 186203
+SHA256 7a21c6f094f39b73ab23653ec628dd78ded47412636c491b3513fa760a8a22d3 gtk-doc-1.8.tar.bz2 186203
diff --git a/dev-util/gtk-doc/gtk-doc-1.8.ebuild b/dev-util/gtk-doc/gtk-doc-1.8.ebuild
new file mode 100644 (file)
index 0000000..a9a3f77
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.8.ebuild,v 1.1 2007/02/19 22:12:55 dang Exp $
+
+inherit elisp-common gnome2
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86"
+IUSE="doc emacs"
+
+RDEPEND=">=dev-lang/perl-5.6
+       >=app-text/openjade-1.3.1
+       dev-libs/libxslt
+       >=dev-libs/libxml2-2.3.6
+       ~app-text/docbook-xml-dtd-4.1.2
+       app-text/docbook-xsl-stylesheets
+       ~app-text/docbook-sgml-dtd-3.0
+       >=app-text/docbook-dsssl-stylesheets-1.40
+       emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+       >=dev-util/pkgconfig-0.19
+       >=app-text/scrollkeeper-0.3.5"
+
+SITEFILE="60gtk-doc-gentoo.el"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+
+src_compile() {
+       gnome2_src_compile
+
+       use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+       gnome2_src_install
+
+       if use doc; then
+               docinto doc
+               dodoc doc/*
+               docinto examples
+               dodoc examples/*
+       fi
+
+       if use emacs; then
+               elisp-install ${PN} tools/gtk-doc.el*
+               elisp-site-file-install ${FILESDIR}/${SITEFILE}
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}