net-fs/autofs: drop old
authorYixun Lan <dlan@gentoo.org>
Fri, 29 May 2020 09:10:53 +0000 (17:10 +0800)
committerYixun Lan <dlan@gentoo.org>
Fri, 29 May 2020 09:10:53 +0000 (17:10 +0800)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Yixun Lan <dlan@gentoo.org>
net-fs/autofs/Manifest
net-fs/autofs/autofs-5.1.5-r2.ebuild [deleted file]

index 8b3aedee33da18c7f18c972c76dd2bd310e3a778..6f533814338845140d2b5723fd45d3ae7907d1dc 100644 (file)
@@ -1,2 +1 @@
-DIST autofs-5.1.5.tar.xz 313476 BLAKE2B 9822f6eb6294a0ee14b08f7982bf6008eb9ac8a79f89cdf3ffa0ed234b83c932db1646fc5591269000372dbfb95ce1b9ded040f0724a7eb4b3888caf20f56a20 SHA512 c8138929a9e2cfa7e0096c1d490b9d7275d1d43a50f5f87ad457bdd9a49c7dd13a4aa5d86ab1e028d66dae630e1a1342661844e5775625fe585867f0f4778898
 DIST autofs-5.1.6.tar.xz 315316 BLAKE2B 0c5e2351462505c6de0b12e510f0c08a625a0235e1ff8eeaff825946c4530c258449d26aaf6a3794aa82a97e8860711226168f434dd31bfb8a4e70287beb3ca4 SHA512 dc8b2bd86c140905dd1bc461bfc469f92363d9c2687fe422e1e751cc7ad64c0733b011c80bf4840e510e5909176cd1a066968b9a5ba835b62c4cf27537863cf2
diff --git a/net-fs/autofs/autofs-5.1.5-r2.ebuild b/net-fs/autofs/autofs-5.1.5-r2.ebuild
deleted file mode 100644 (file)
index 31f4171..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="Kernel based automounter"
-HOMEPAGE="https://web.archive.org/web/*/http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
-SRC_URI="https://www.kernel.org/pub/linux/daemons/${PN}/v5/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="-dmalloc ldap +libtirpc mount-locking sasl systemd"
-
-# currently, sasl code assumes the presence of kerberosV
-RDEPEND=">=sys-apps/util-linux-2.20
-       dmalloc? ( dev-libs/dmalloc[threads] )
-       ldap? ( >=net-nds/openldap-2.0
-               sasl? (
-                       dev-libs/cyrus-sasl
-                       dev-libs/libxml2
-                       virtual/krb5
-               )
-       )
-       systemd? ( sys-apps/systemd )
-       libtirpc? ( net-libs/libtirpc )
-       !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
-"
-DEPEND="${RDEPEND}
-       libtirpc? ( net-libs/rpcsvc-proto )
-"
-BDEPEND="
-       sys-devel/flex
-       virtual/yacc
-"
-
-pkg_setup() {
-       linux-info_pkg_setup
-
-       local CONFIG_CHECK
-
-       if kernel_is -ge 4 18; then
-               CONFIG_CHECK="~AUTOFS_FS"
-       else
-               CONFIG_CHECK="~AUTOFS4_FS"
-       fi
-
-       check_extra_config
-}
-
-src_prepare() {
-       sed -i  -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die # bug #479492
-       sed -i  -e "/^EnvironmentFile/d"        samples/autofs.service.in || die # bug #592334
-
-       # Install samples including autofs.service
-       sed -i -e "/^SUBDIRS/s/$/ samples/g" Makefile.rules || die
-
-       default
-}
-
-src_configure() {
-       # bug #483716
-       tc-export AR
-       # --with-confdir is for bug #361481
-       # --with-mapdir is for bug #385113
-       local myeconfargs=(
-               --with-confdir=/etc/conf.d
-               --with-mapdir=/etc/autofs
-               $(use_with dmalloc)
-               $(use_with ldap openldap)
-               $(use_with libtirpc)
-               $(use_with sasl)
-               $(use_enable mount-locking)
-               $(use_with systemd systemd $(systemd_get_systemunitdir)) # bug #479492
-               --without-hesiod
-               --disable-ext-env
-               --enable-sloppy-mount # bug #453778
-               --enable-force-shutdown
-               --enable-ignore-busy
-               RANLIB="$(type -P $(tc-getRANLIB))" # bug #483716
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       default
-       rmdir "${D}"/run
-
-       if kernel_is -lt 2 6 30; then
-               # kernel patches
-               docinto patches
-               dodoc patches/${PN}4-2.6.??{,.?{,?}}-v5-update-????????.patch
-       fi
-       newinitd "${FILESDIR}"/autofs5.initd autofs
-       insinto etc/autofs
-       newins "${FILESDIR}"/autofs5-auto.master auto.master
-}
-
-pkg_postinst() {
-       if kernel_is -lt 2 6 30; then
-               elog "This version of ${PN} requires a kernel with autofs4 supporting"
-               elog "protocol version 5.00. Patches for kernels older than 2.6.30 have"
-               elog "been installed into"
-               elog "${EROOT}/usr/share/doc/${P}/patches."
-               elog "For further instructions how to patch the kernel, please refer to"
-               elog "${EROOT}/usr/share/doc/${P}/INSTALL."
-               elog
-       fi
-       elog "If you plan on using autofs for automounting remote NFS mounts,"
-       elog "please check that both portmap (or rpcbind) and rpc.statd/lockd"
-       elog "are running."
-}