media-libs/libvpx: fix building on ppc
authorStephan Hartmann <stha09@googlemail.com>
Tue, 19 Nov 2019 15:59:08 +0000 (16:59 +0100)
committerMike Gilbert <floppym@gentoo.org>
Wed, 20 Nov 2019 19:28:17 +0000 (14:28 -0500)
Closes: https://bugs.gentoo.org/694368
Thanks-to: ernsteiswuerfel <erhard_f@mailbox.org>
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/13714

media-libs/libvpx/libvpx-1.7.0.ebuild
media-libs/libvpx/libvpx-1.8.0-r1.ebuild
media-libs/libvpx/libvpx-1.8.0.ebuild

index 877d221cedb933c4186bf98c999e8b4fe671c831..752360e5cbe5d430f21ad5a64b6d93a06da1edb4 100644 (file)
@@ -95,6 +95,9 @@ multilib_src_configure() {
                x86_64*) export AS=yasm;;
        esac
 
+       # powerpc toolchain is not recognized anymore, #694368
+       [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
        # Build with correct toolchain.
        tc-export CC CXX AR NM
        # Link with gcc by default, the build system should override this if needed.
index 9c2b048cea49f946a8dfa6221a4045dbcef67329..f0bd958474967d1eb7c0ee3da22ed1f1d58f8cdc 100644 (file)
@@ -84,6 +84,9 @@ multilib_src_configure() {
                x86_64*) export AS=yasm;;
        esac
 
+       # powerpc toolchain is not recognized anymore, #694368
+       [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
        # Build with correct toolchain.
        tc-export CC CXX AR NM
        # Link with gcc by default, the build system should override this if needed.
index 5d7954ec89c152beddcfa65e8dc7f6f22d2f02ff..a05ed4eb72ff59aefd114d33d644e997a237e2eb 100644 (file)
@@ -96,6 +96,9 @@ multilib_src_configure() {
                x86_64*) export AS=yasm;;
        esac
 
+       # powerpc toolchain is not recognized anymore, #694368
+       [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
        # Build with correct toolchain.
        tc-export CC CXX AR NM
        # Link with gcc by default, the build system should override this if needed.