app-emacs/sml-mode: Bump to version 6.9.
authorUlrich Müller <ulm@gentoo.org>
Wed, 16 Oct 2019 16:13:36 +0000 (18:13 +0200)
committerUlrich Müller <ulm@gentoo.org>
Wed, 16 Oct 2019 16:58:47 +0000 (18:58 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/sml-mode/Manifest
app-emacs/sml-mode/sml-mode-6.9.ebuild [new file with mode: 0644]

index 983136bf9252118d617db2eadaf3a9feb60a288f..7c4e5cf9d49f0fd787090274cf48a390d44d12ec 100644 (file)
@@ -1 +1,2 @@
 DIST sml-mode-6.4.el.xz 20512 BLAKE2B ec82b44e7e1ff9d4c89ffdec6d29afddb2bb5a62474dfef417409496fd374373aca53f3a850990972e888ec2dc006606a06c63e327316e28552273d7995cd38e SHA512 238c69cf34bdd9b825fdc00e65741a458e64bf4bf38ed96ba0518154dd92f25877d56d09f4c13271577ea8641ca828023db950db07a42fe1a02659527b65cb5b
+DIST sml-mode-6.9.el.xz 20368 BLAKE2B 5b97c6620d97a60f29e21e8d69179e33f56b7410bf975238e23ef10d4c9e8d7dc250cb60d1799224ac6c81285f539cbb7f69b616763b347ed7140b9652b9add7 SHA512 e04143e1017317d6c6fb3ad7a26cd812bb45dd406a5fb679be21ae936ab57739bcf692585d5710a8e08c469a07728a20cb71ff1b53661c4040eb16df55c8be0b
diff --git a/app-emacs/sml-mode/sml-mode-6.9.ebuild b/app-emacs/sml-mode/sml-mode-6.9.ebuild
new file mode 100644 (file)
index 0000000..dd9b5fb
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="https://elpa.gnu.org/packages/sml-mode.html
+       http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+       elisp-compile *.el
+       elisp-make-autoload-file
+}