xfce-base/xfwm4: Bump to 4.12.5 (stable branch)
authorMichał Górny <mgorny@gentoo.org>
Sat, 4 Aug 2018 10:29:15 +0000 (12:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 4 Aug 2018 10:40:06 +0000 (12:40 +0200)
xfce-base/xfwm4/Manifest
xfce-base/xfwm4/xfwm4-4.12.5.ebuild [new file with mode: 0644]

index a17a6ce3a21347da79bb6cdd0d72450a68273e6c..9a7a65bf9d113881385ae6008f770054400b9ac4 100644 (file)
@@ -1,2 +1,3 @@
 DIST xfwm4-4.12.4.tar.bz2 1208874 BLAKE2B 60b584d71bc4696bae83897d80cd90d9c13233d1971c823eea6417c8020a0440dc0d648df4e11b27947915ca57130ea3bc7b588e902dc7db74945349ff9ac514 SHA512 a33530b08f094456c45ad7c627ba34d3772eaeacdc9f422a3a54a16194d494cb1d6798122398d917fb8bc970db7e1184d9dc8edefc365dacc86de22be397b43d
+DIST xfwm4-4.12.5.tar.bz2 1215450 BLAKE2B 3a156af589ec7391245edbedbc6e10ac9c746121f68e4bd0c64e30b9b0c11abfe13c1fb77321249edd4e5c8d3051f62f135093fabfd8ba215573d330fd3745c2 SHA512 b723638b9cd858beb75232a251471cfb2d01ddb412b536c3f0b432e1f894014e1ad51c77d208d5439ae8a8d970344d0146d5f9475106c1b66d22715af7af42d9
 DIST xfwm4-4.13.0.tar.bz2 1229878 BLAKE2B 9d7f3d6121a1d1522294a659204d391e120b971cbca00f53f0a0d37f256f2ad65dc6ac1cfd5355d78fa5bd811ed8f7d4013081a10470f18e3edb9fcc0395e218 SHA512 01c6cc31dc179ccb51f9881f64ee9e4e16320ab888381d0b203ca0b2a46097048c30eabe7083aaec869c80e8e358c287896d6a1965a36ed6f2f981c27cfb2dce
diff --git a/xfce-base/xfwm4/xfwm4-4.12.5.ebuild b/xfce-base/xfwm4/xfwm4-4.12.5.ebuild
new file mode 100644 (file)
index 0000000..b1ef18f
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dri startup-notification +xcomposite"
+
+RDEPEND="dev-libs/dbus-glib:=
+       >=dev-libs/glib-2.20:=
+       >=x11-libs/gtk+-2.24:2=
+       x11-libs/libX11:=
+       x11-libs/libXext:=
+       x11-libs/libXinerama:=
+       x11-libs/libXrandr:=
+       x11-libs/libXrender:=
+       x11-libs/pango:=
+       >=x11-libs/libwnck-2.30:1=
+       >=xfce-base/libxfce4util-4.10:=
+       >=xfce-base/libxfce4ui-4.11:=
+       >=xfce-base/xfconf-4.10:=
+       startup-notification? ( x11-libs/startup-notification:= )
+       xcomposite? (
+               x11-libs/libXcomposite:=
+               x11-libs/libXdamage:=
+               x11-libs/libXfixes:=
+               )"
+# libdrm: only headers are used
+# libICE/liBSM: not really used anywhere but checked by configure
+#   https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       x11-libs/libICE
+       x11-libs/libSM
+       xfce-base/exo
+       virtual/pkgconfig
+       dri? ( >=x11-libs/libdrm-2.4 )"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+       local myconf=(
+               $(use_enable dri libdrm)
+               $(use_enable startup-notification)
+               --enable-xsync
+               --enable-render
+               --enable-randr
+               $(use_enable xcomposite compositor)
+       )
+
+       econf "${myconf[@]}"
+}