*/*: Switch kde proj packages using cmake-multilib.eclass to cmake
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 21 Dec 2019 12:57:48 +0000 (13:57 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 29 Dec 2019 13:03:43 +0000 (14:03 +0100)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/cmocka/cmocka-1.1.5.ebuild
media-gfx/exiv2/exiv2-0.27.2.ebuild
media-libs/taglib/taglib-1.11.1_p20190920-r1.ebuild
net-libs/libssh/libssh-0.9.0.ebuild
net-libs/libssh/libssh-0.9.3.ebuild
net-libs/libssh/libssh-9999.ebuild
x11-themes/oxygen-gtk/oxygen-gtk-1.4.1-r1.ebuild
x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild

index eecc4f26cc8c55784e3e19cd0eee18e6b35cd3b6..1d03a71769148e74a5720b8513a5231450828e85 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="Unit testing framework for C"
@@ -24,16 +25,16 @@ multilib_src_configure() {
                -DWITH_EXAMPLES=$(usex examples)
                -DWITH_STATIC_LIB=$(usex static-libs)
                -DUNIT_TESTING=$(usex test)
-               $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
+               $(multilib_is_native_abi && cmake_use_find_package doc Doxygen \
                        || echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
-       multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+       cmake_src_compile
+       multilib_is_native_abi && use doc && cmake_src_compile docs
 }
 
 multilib_src_install() {
@@ -41,5 +42,5 @@ multilib_src_install() {
                local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
        fi
 
-       cmake-utils_src_install
+       cmake_src_install
 }
index 3d6060c5535eee6c9da428ef04104ce6cf450542..b1ac0f0a6b3d4dc9894cf62d89587a9e9ad00e2d 100644 (file)
@@ -11,6 +11,7 @@ else
        KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
 fi
 
+CMAKE_ECLASS=cmake
 PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 inherit cmake-multilib python-any-r1
 
@@ -59,7 +60,7 @@ src_prepare() {
        iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
        mv -f doc/cmd.txt.tmp doc/cmd.txt || die
 
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
 }
@@ -79,11 +80,11 @@ multilib_src_configure() {
                -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
+       cmake_src_compile
 
        if multilib_is_native_abi; then
                use doc && eninja doc
index 5cac4484ce057d2883e01f069fd0b8991eced14b..f6f6fbf93eb2557b4059275af9f9f0cfb3f48b0b 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 COMMIT=54508df30bc888c4d2359576ceb0cc8f2fa8dbdf
 inherit cmake-multilib
 
@@ -35,7 +36,7 @@ MULTILIB_CHOST_TOOLS=(
 S="${WORKDIR}/${PN}-${COMMIT}"
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        sed -e "s/BUILD_TESTS AND NOT BUILD_SHARED_LIBS/BUILD_TESTS/" \
                -i CMakeLists.txt \
@@ -48,5 +49,5 @@ multilib_src_configure() {
                -DBUILD_TESTS=$(usex test)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
index b13f672c4840b42ce51db7a9301a65f66cf31ade..759da6a2fc0927b99f43ab1daddee81dd03c1e49 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="Access a working SSH implementation by means of a library"
@@ -49,7 +50,7 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # just install the examples, do not compile them
        cmake_comment_add_subdirectory examples
@@ -88,16 +89,16 @@ multilib_src_configure() {
 
        multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
-       multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+       cmake_src_compile
+       multilib_is_native_abi && use doc && cmake_src_compile docs
 }
 
 multilib_src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
 
        # compatibility symlink until all consumers have been updated
index 3ead343c58fea54487d729f17f91e73ea7fc4d4b..c015fb647b0ec6b3a2ccb927413fe1a2629568f6 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="Access a working SSH implementation by means of a library"
@@ -49,7 +50,7 @@ PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
 RESTRICT+=" !test? ( test )"
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # just install the examples, do not compile them
        cmake_comment_add_subdirectory examples
@@ -88,16 +89,16 @@ multilib_src_configure() {
 
        multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
-       multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+       cmake_src_compile
+       multilib_is_native_abi && use doc && cmake_src_compile docs
 }
 
 multilib_src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
 
        use static-libs && dolib.a src/libssh.a
index e86e51662ed2bf55574fecd21dcc99e291db768c..8ddb3caa00db89912139f28ed836786db43c3d0b 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 inherit cmake-multilib
 
 DESCRIPTION="Access a working SSH implementation by means of a library"
@@ -49,7 +50,7 @@ PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
 RESTRICT+=" !test? ( test )"
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # just install the examples, do not compile them
        cmake_comment_add_subdirectory examples
@@ -88,16 +89,16 @@ multilib_src_configure() {
 
        multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 multilib_src_compile() {
-       cmake-utils_src_compile
-       multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+       cmake_src_compile
+       multilib_is_native_abi && use doc && cmake_src_compile docs
 }
 
 multilib_src_install() {
-       cmake-utils_src_install
+       cmake_src_install
        multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
 
        use static-libs && dolib.a src/libssh.a
index 803e8e61400a0a0a3b8c43e9642cd380d2bab52d..8f1e41d55b76a4d6639d59fe7123cc7b368a01b1 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 MY_PN=${PN}3
 MY_P=${MY_PN}-${PV}
 inherit cmake-multilib
@@ -44,7 +45,7 @@ multilib_src_configure() {
                        -DENABLE_DEMO=OFF
                )
        fi
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {
index 9b9e4ced8f7face89ce837f71bc77e066d7aeebd..deac2e20f0e32624920be69b88efa6c4acaa57d0 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+CMAKE_ECLASS=cmake
 MY_PN=${PN}2
 MY_P=${MY_PN}-${PV}
 inherit cmake-multilib
@@ -47,7 +48,7 @@ multilib_src_configure() {
                        -DENABLE_DEMO=OFF
                )
        fi
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_install() {