version bump; adjusted ghostscript dependency to virtual/ghostscript, as the problem...
authorChristian Faulhammer <fauli@gentoo.org>
Thu, 18 Jan 2007 11:59:52 +0000 (11:59 +0000)
committerChristian Faulhammer <fauli@gentoo.org>
Thu, 18 Jan 2007 11:59:52 +0000 (11:59 +0000)
Package-Manager: portage-2.1.1-r2

sci-misc/gri/ChangeLog
sci-misc/gri/files/digest-gri-2.12.14 [new file with mode: 0644]
sci-misc/gri/gri-2.12.14.ebuild [new file with mode: 0644]

index b06cbf544991140a882d23d47e5e3c5430c760c8..4a9b6f3945c422a7d9b6a48d4c07725e0344972d 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for sci-misc/gri
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/ChangeLog,v 1.8 2006/12/07 12:41:19 opfer Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/ChangeLog,v 1.9 2007/01/18 11:59:52 opfer Exp $
+
+*gri-2.12.14 (18 Jan 2007)
+
+  18 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
+  -files/info-install.patch, +gri-2.12.14.ebuild:
+  version bump; adjusted ghostscript dependency to virtual/ghostscript, as the
+  problem is resolved, reported by James Cloos <cloos@jhcloos.com> in bug
+  162630; added some quotes; removed stray patch
 
 *gri-2.12.13 (07 Dec 2006)
 
diff --git a/sci-misc/gri/files/digest-gri-2.12.14 b/sci-misc/gri/files/digest-gri-2.12.14
new file mode 100644 (file)
index 0000000..c501f12
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0c89d6b38b6c0ed31aa6c24d43ed5123 gri-2.12.14.tar.gz 1622875
+RMD160 1f110e4d2690d881870ab287274995fb9603f89f gri-2.12.14.tar.gz 1622875
+SHA256 120f88cfc93adc5f796114f512cc8a11d81b56a604adc59d1e786d27404a4e8e gri-2.12.14.tar.gz 1622875
diff --git a/sci-misc/gri/gri-2.12.14.ebuild b/sci-misc/gri/gri-2.12.14.ebuild
new file mode 100644 (file)
index 0000000..eb53882
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gri/gri-2.12.14.ebuild,v 1.1 2007/01/18 11:59:52 opfer Exp $
+
+inherit eutils elisp-common
+
+IUSE="emacs"
+
+DESCRIPTION="language for scientific graphics programming"
+HOMEPAGE="http://gri.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gri/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=">=sci-libs/netcdf-3.5.0
+       virtual/tetex
+       media-gfx/imagemagick
+       virtual/ghostscript
+       emacs? ( virtual/emacs )"
+
+SITEFILE="50gri-gentoo.el"
+
+src_compile() {
+       econf || die "econf failed."
+       emake || die "emake failed."
+       if use emacs; then
+               pushd src; elisp-comp *.el; popd
+       fi
+}
+
+src_install() {
+       # Replace PREFIX now and correct paths in the startup message.
+       sed -e s,PREFIX/share/doc/gri/,/usr/share/doc/${P}/, -i ${S}/startup.msg
+
+       einstall || die "einstall failed."
+
+       dodoc AUTHOR README
+       #move docs to the proper place
+       mv "${D}/usr/share/gri/doc/*" "${D}/usr/share/doc/${PF}"
+       rmdir "${D}/usr/share/gri/doc/"
+
+       if use emacs; then
+               pushd src
+               elisp-install gri *.{el,elc}
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+               popd
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}