Revbump that stops symlinking the jar into ant-core/lib, for split-ant aware revision...
authorVlastimil Babka <caster@gentoo.org>
Mon, 12 Feb 2007 00:53:52 +0000 (00:53 +0000)
committerVlastimil Babka <caster@gentoo.org>
Mon, 12 Feb 2007 00:53:52 +0000 (00:53 +0000)
Package-Manager: portage-2.1.2-r9

dev-java/xjavac/ChangeLog
dev-java/xjavac/files/digest-xjavac-20041208-r5 [new file with mode: 0644]
dev-java/xjavac/xjavac-20041208-r4.ebuild
dev-java/xjavac/xjavac-20041208-r5.ebuild [new file with mode: 0644]

index c8df78bb9d9a4cef78fb0d38ce542013d6d48195..2ddcde95993b5809c122f283d65922c49740ba96 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-java/xjavac
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/ChangeLog,v 1.19 2007/01/27 22:25:02 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/ChangeLog,v 1.20 2007/02/12 00:53:52 caster Exp $
+
+*xjavac-20041208-r5 (12 Feb 2007)
+
+  12 Feb 2007; Vlastimil Babka <caster@gentoo.org>
+  xjavac-20041208-r4.ebuild, +xjavac-20041208-r5.ebuild:
+  Revbump that stops symlinking the jar into ant-core/lib, for split-ant aware
+  revisions of xerces.
 
   27 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
   -xjavac-20041208-r1.ebuild, -xjavac-20041208-r2.ebuild,
diff --git a/dev-java/xjavac/files/digest-xjavac-20041208-r5 b/dev-java/xjavac/files/digest-xjavac-20041208-r5
new file mode 100644 (file)
index 0000000..b707505
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 47e450883782e191e0e91c31a6dc2caf xjavac-20041208.tar.gz 1971
+RMD160 bdee4c165275dedcfaf42fd38962a85b668d259e xjavac-20041208.tar.gz 1971
+SHA256 ae54e392bfe3ff5d33bc58a7e122bdae863531e235c2a553dee024e045694781 xjavac-20041208.tar.gz 1971
index c870873ae0894eebfc15b421ca9c5b5e3e0d9e5c..77b813c8bcda2c7c652afb18484912580189ae9d 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r4.ebuild,v 1.6 2007/01/05 21:46:37 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r4.ebuild,v 1.7 2007/02/12 00:53:52 caster Exp $
 
-inherit java-pkg-2
+inherit java-pkg-2 java-ant-2
 
 DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
 SRC_URI="mirror://gentoo/${P}.tar.gz"
diff --git a/dev-java/xjavac/xjavac-20041208-r5.ebuild b/dev-java/xjavac/xjavac-20041208-r5.ebuild
new file mode 100644 (file)
index 0000000..794a600
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r5.ebuild,v 1.1 2007/02/12 00:53:52 caster Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/tools/src/XJavac.java"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+DEPEND=">=virtual/jdk-1.4
+       >=dev-java/ant-core-1.4"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       cp ${FILESDIR}/${P}-build.xml ./build.xml || die" failed to cp build.xml"
+       epatch "${FILESDIR}/${PN}-ibm-1_5.patch"
+       epatch "${FILESDIR}/${PN}-more-vendors.patch"
+}
+
+src_compile() {
+       eant jar -Dclasspath=$(java-pkg_getjars ant-core)
+}
+
+src_install() {
+       java-pkg_dojar dist/${PN}.jar
+}