Initial import
authorJeremy Huddleston <eradicator@gentoo.org>
Wed, 31 Mar 2004 01:57:46 +0000 (01:57 +0000)
committerJeremy Huddleston <eradicator@gentoo.org>
Wed, 31 Mar 2004 01:57:46 +0000 (01:57 +0000)
net-libs/libhttpd-persistent/ChangeLog [new file with mode: 0644]
net-libs/libhttpd-persistent/Manifest [new file with mode: 0644]
net-libs/libhttpd-persistent/files/digest-libhttpd-persistent-1.3p-r6 [new file with mode: 0644]
net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild [new file with mode: 0644]
net-libs/libhttpd-persistent/metadata.xml [new file with mode: 0644]

diff --git a/net-libs/libhttpd-persistent/ChangeLog b/net-libs/libhttpd-persistent/ChangeLog
new file mode 100644 (file)
index 0000000..a3a0894
--- /dev/null
@@ -0,0 +1,27 @@
+# ChangeLog for net-libs/libhttpd-persistent
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/ChangeLog,v 1.1 2004/03/31 01:57:46 eradicator Exp $
+
+*libhttpd-persistent-1.3p-r6 (30 Mar 2004)
+
+  30 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+  libhttpd-persistent-1.3p-r6.ebuild, metadata.xml:
+  Added to portage.
+
+  03 Dec 2003; Sandy McArthur <sandymac@gentoo.org> libhttpd-persistent-1.3p-r6.ebuild :
+  New upstream release: libhttpd-persistent (bugfix version f). Changes in this release
+  are: "Renamed libhttpd to libhttpd-persistent to allow both versions to be installed
+  at the same time. This became neccessary because libhttpd-persistent turned out to be
+  incompatible to the old version."
+
+*libhttpd-persistent-1.3p-r5 (25 Nov 2003)
+
+  25 Nov 2003; Sandy McArthur <sandymac@gentoo.org> libhttpd-persistent-1.3p-r5.ebuild :
+  Created ebuild for libhttpd-persistent-1.3p-e which patched the Site.mm file
+  to allow this verion to compile on Gentoo. Release -e is a bugfix release.
+
+*libhttpd-persistent-1.3p-r4 (24 Nov 2003)
+
+  24 Nov 2003; Sandy McArthur <sandymac@gentoo.org> :
+  Initial import.  Ebuild submitted by Sandy McArthur <sandymac@gentoo.org>.
+  There is a newer version of this package but it does not compile on Gentoo.
diff --git a/net-libs/libhttpd-persistent/Manifest b/net-libs/libhttpd-persistent/Manifest
new file mode 100644 (file)
index 0000000..bf91da0
--- /dev/null
@@ -0,0 +1,4 @@
+MD5 0f4d3870679c2430e8daac694d3b7f2f libhttpd-persistent-1.3p-r6.ebuild 1451
+MD5 57ebfd6e34011c863844568dee206770 ChangeLog 1348
+MD5 34371b0b6264e8222d4666bf5895f5f7 metadata.xml 432
+MD5 3d54fde5d128291ea5a6ae6dd4f9d840 files/digest-libhttpd-persistent-1.3p-r6 64
diff --git a/net-libs/libhttpd-persistent/files/digest-libhttpd-persistent-1.3p-r6 b/net-libs/libhttpd-persistent/files/digest-libhttpd-persistent-1.3p-r6
new file mode 100644 (file)
index 0000000..989c55a
--- /dev/null
@@ -0,0 +1 @@
+MD5 97f464bbf08908db9cec9baa24f6159e libhttpd-1.3p-f.tgz 155140
diff --git a/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild b/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild
new file mode 100644 (file)
index 0000000..0e7ebc8
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhttpd-persistent/libhttpd-persistent-1.3p-r6.ebuild,v 1.1 2004/03/31 01:57:46 eradicator Exp $
+
+MY_P="libhttpd-1.3p-f"
+
+DESCRIPTION="libhttpd-persistent is a modified version of David Hughes' libhttpd."
+HOMEPAGE="http://www.deleet.de/projekte/daap/daapd/"
+SRC_URI="http://www.deleet.de/projekte/daap/daapd/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+S="${WORKDIR}/libhttpd-1.3-persistent-f"
+
+src_compile() {
+       econf || die
+
+       # This is for versions since libhttpd-1.3p-e until the configure
+       # process properly detects g++
+       sed -i 's:gcc:g++:' Site.mm
+       # end gcc to g++ edits.
+
+       emake || die
+
+       cd ${S}/src
+       ranlib libhttpd-persistent.a
+       echo g++ ${CFLAGS} -D_OS_UNIX -fPIC protocol.c api.c version.c ip_acl.c select.c -o libhttpd-persistent.so -Wl,-shared,-soname,libhttpd-persistent.so
+       g++ ${CFLAGS} -D_OS_UNIX -fPIC protocol.c api.c version.c ip_acl.c select.c -o libhttpd-persistent.so -Wl,-shared,-soname,libhttpd-persistent.so
+}
+
+src_install() {
+       # This pacakge doesn't respect anything autoconf-ish
+       dolib.a src/libhttpd-persistent.a
+       dolib.so src/libhttpd-persistent.so
+
+       mkdir -p ${D}/usr/include/
+       cp src/httpd-persistent.h ${D}/usr/include/
+       chmod 644 ${D}/usr/include/httpd-persistent.h
+
+       dodoc HISTORY License README doc/FAQ.txt doc/libhttpd.pdf
+}
diff --git a/net-libs/libhttpd-persistent/metadata.xml b/net-libs/libhttpd-persistent/metadata.xml
new file mode 100644 (file)
index 0000000..2e27808
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+  <email>eradicator@gentoo.org</email>
+  <name>Jeremy Huddleston</name>
+ </maintainer>
+ <longdescription>
+  libhttpd-persistent is a modified version of David Hughes' libhttpd
+  available from http://www.hughes.com.au/products/libhttpd/
+ </longdescription>
+</pkgmetadata>