dev-libs/leatherman: 1.6.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 16 Jul 2019 15:02:48 +0000 (10:02 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 16 Jul 2019 15:06:27 +0000 (10:06 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/leatherman/Manifest
dev-libs/leatherman/leatherman-1.6.1.ebuild [new file with mode: 0644]

index c5491e904f25bab534cfe6a26dbc7928b0d8a6a5..7680d7d718e9d24431fca8166ad2c1d46088d4d4 100644 (file)
@@ -1,2 +1,3 @@
 DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
 DIST leatherman-1.6.0.tar.gz 814463 BLAKE2B 1c990c261ded1fd32bb5b1912f84a4bef8ac3ccfae9172e0496f90283e1a2ac210bf9dc1c7e88bcb8776798674d93c1313359135051b4c7f023e1e3080104e2e SHA512 d0d22b60db2c164183268d29fe1bc1ee9ed16797d38174849eaa74841f801869d038e5672664aae89517487811a70f689a345a2c87d3a2f0a04d55214e7f9eaa
+DIST leatherman-1.6.1.tar.gz 814463 BLAKE2B b3370eaf1312894dadb9e754869cf72d498c452ef4c740acc9550d1c3fd881a673439f35fcfe2475635869910df52e81d0cc9b97a7a2fc62227a14376297f55b SHA512 0803b985b57bd5e34ba31137b31fdfece53cb545dffb6a9447aa3de0353c9300e2d9e41b2b4f761b7683e02ed6577decfb1938d238314fd8439eccb16aa9475a
diff --git a/dev-libs/leatherman/leatherman-1.6.1.ebuild b/dev-libs/leatherman/leatherman-1.6.1.ebuild
new file mode 100644 (file)
index 0000000..3354269
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54:=[nls]
+       net-misc/curl
+       >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+       sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_VERBOSE_MAKEFILE=ON
+               -DCMAKE_BUILD_TYPE=None
+               -DCMAKE_INSTALL_PREFIX=/usr
+       )
+       if ! use static-libs; then
+               mycmakeargs+=(
+                       -DLEATHERMAN_SHARED=ON
+               )
+       else
+               mycmakeargs+=(
+                       -DLEATHERMAN_SHARED=OFF
+               )
+       fi
+       if use debug; then
+               mycmakeargs+=(
+                 -DCMAKE_BUILD_TYPE=Debug
+               )
+       fi
+       cmake-utils_src_configure
+}
+
+src_test() {
+       "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+       cmake-utils_src_install
+}