dev-perl/CGI-Ajax: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Wed, 6 May 2020 17:59:30 +0000 (05:59 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 6 May 2020 17:59:30 +0000 (05:59 +1200)
- EAPI7
- Parallel tests

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/CGI-Ajax/CGI-Ajax-0.707.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/CGI-Ajax/CGI-Ajax-0.707.0-r1.ebuild b/dev-perl/CGI-Ajax/CGI-Ajax-0.707.0-r1.ebuild
new file mode 100644 (file)
index 0000000..3159244
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_VERSION=0.707
+DIST_AUTHOR=BPEDERSE
+inherit perl-module
+
+DESCRIPTION="a perl-specific system for writing Asynchronous web applications"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-perl/CGI
+       dev-perl/Class-Accessor
+"
+BDEPEND="${RDEPEND}
+       test? ( virtual/perl-Test-Simple )
+"