Suggestion from Brian Harring to remove extra processing, condense code.
authorAlec Warner <antarus@gentoo.org>
Wed, 22 Feb 2006 21:20:16 +0000 (21:20 -0000)
committerAlec Warner <antarus@gentoo.org>
Wed, 22 Feb 2006 21:20:16 +0000 (21:20 -0000)
svn path=/main/trunk/; revision=2762

bin/repoman

index b94c6459e428c26da6667ddd20f722fad70abbc5..c68beb68ecf06090f1a4a7e877ca365036d82d30 100755 (executable)
@@ -972,7 +972,7 @@ for x in scanlist:
                        fails["ebuild.namenomatch"].append(x+"/"+y+".ebuild")
                        continue
                try:
-                       myaux=portage.db["/"]["porttree"].dbapi.aux_get(catdir+"/"+y,allvars)
+                       myaux = dict( zip(allvars, portage.db["/"]["porttree"].dbapi.aux_get(catdir+"/"+y, allvars ) )
                except KeyError:
                        stats["ebuild.syntax"]=stats["ebuild.syntax"]+1
                        fails["ebuild.syntax"].append(x+"/"+y+".ebuild")
@@ -982,14 +982,6 @@ for x in scanlist:
                        fails["ebuild.output"].append(x+"/"+y+".ebuild")
                        continue
 
-               mynewaux = {}
-               for idx in range(len(allvars)):
-                       if idx < len(myaux):
-                               mynewaux[allvars[idx]] = myaux[idx]
-                       else:
-                               mynewaux[allvars[idx]] = ""
-               myaux = mynewaux
-
                # Test for negative logic and bad words in the RESTRICT var.
                #for x in myaux[allvars.index("RESTRICT")].split():
                #       if x.startswith("no"):