games-simulation/micropolis: Use safer sed delimiter
authorHanno Böck <hanno@gentoo.org>
Sat, 9 May 2020 10:40:55 +0000 (12:40 +0200)
committerHanno Böck <hanno@gentoo.org>
Sat, 9 May 2020 10:40:55 +0000 (12:40 +0200)
Closes: https://bugs.gentoo.org/710964
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22

games-simulation/micropolis/micropolis-1.0_p20180313.ebuild

index c1c8bfccecec74092327a59e6f68bb7ba180060f..9b54f5d50580797761acd965577649e9ca7f3b7d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -27,9 +27,9 @@ S="${WORKDIR}/${PN}-${COMMIT}"
 src_prepare() {
        default
 
-       sed -i -e "s:-O3:${CFLAGS}:" \
+       sed -i -e "s|-O3|${CFLAGS}|" \
                src/tclx/config.mk src/{sim,tcl,tk}/makefile || die
-       sed -i -e "s:XLDFLAGS=:&${LDFLAGS}:" \
+       sed -i -e "s|XLDFLAGS=|&${LDFLAGS}|" \
                src/tclx/config.mk || die
 }