dev-python/atom: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:11:27 +0000 (17:11 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:11:27 +0000 (17:11 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/atom/atom-0.4.1.ebuild

index 413485df8be2665502b14ab3af06f3d1d2a8d728..f5e696e65dd8b6b587202dfea46299bc3586d388 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
 inherit distutils-r1 flag-o-matic
 
 DESCRIPTION="Memory efficient Python objects"
@@ -22,12 +22,3 @@ DEPEND="
        test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 
 RESTRICT="test"
-
-python_prepare_all() {
-       append-flags -fno-strict-aliasing
-       distutils-r1_python_prepare_all
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-}