lxde-base/lxrandr: Version bump to 0.3.2 and EAPI=7
authorcharIes17 <charles17@arcor.de>
Tue, 7 May 2019 09:53:39 +0000 (11:53 +0200)
committerHanno <hanno@gentoo.org>
Tue, 7 May 2019 14:28:55 +0000 (16:28 +0200)
Closes: https://bugs.gentoo.org/681962
Closes: https://github.com/gentoo/gentoo/pull/11927
Signed-off-by: Hanno Boeck <hanno@gentoo.org>
lxde-base/lxrandr/Manifest
lxde-base/lxrandr/lxrandr-0.3.2.ebuild [new file with mode: 0644]

index a401e281578226fb5a0000fa4ce7cee4a6636686..eba3b0166df6214d877115bc801cbb81ce03d9ab 100644 (file)
@@ -1 +1,2 @@
 DIST lxrandr-0.3.1.tar.xz 132468 BLAKE2B 04ea378eaa550a1610f4083524c48dab6e261301dc30262fc34049d89d3b29b02d8ad2c521fc3beab1be416b54560dcb87bb2fc27261e35cb27771fbc7bbe9ee SHA512 525cb8800045f26cb1ecae994e1663db4ce41fbfcf1eabd6c50de38988324cd50f51167fa0caa6872867955c0d18af115bed1d4ae896cb15871efd477eb01196
+DIST lxrandr-0.3.2.tar.xz 134072 BLAKE2B 8c8e7985b20c4b90d610b51ffbb7c6f02096f9b2550ea69f16bd0ae8840456a605d646d83cb2a70550a84aaca87deb6496b811fe79990cf36994b2b66aee7915 SHA512 9f00f885e4af3544d9bf8a7581d5b9e3049c1fac174c119dda8c85f2f94aa7be241b6e06e5fe86596a0fb65a38bfe1983ced91c064339a60b19f506ed337ee4f
diff --git a/lxde-base/lxrandr/lxrandr-0.3.2.ebuild b/lxde-base/lxrandr/lxrandr-0.3.2.ebuild
new file mode 100644 (file)
index 0000000..d7ba21d
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLOCALES="af ar ast be bg bn_IN bn ca cs da de el en_GB es et eu fa fi fo
+fr frp gl he hr hu id is ja kk ko lg lt ml ms nb nl nn pa pl ps pt_BR pt
+ro ru sk sl sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n
+
+DESCRIPTION="LXDE GUI interface to RandR extention"
+HOMEPAGE="https://wiki.lxde.org/en/LXRandR"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+       x11-libs/libXrandr
+       x11-apps/xrandr"
+DEPEND="${RDEPEND}
+       >=dev-util/intltool-0.40.0
+       sys-devel/gettext
+       virtual/pkgconfig
+       x11-base/xorg-proto"
+
+src_prepare() {
+       default
+       export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+       l10n_get_locales > po/LINGUAS || die
+}