dev-ada/xmlada: add gnat_2016 and gnat_2017 use flags to select the compiler
authorTupone Alfredo <tupone@gentoo.org>
Mon, 26 Jun 2017 20:06:28 +0000 (22:06 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 26 Jun 2017 20:06:28 +0000 (22:06 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

dev-ada/xmlada/metadata.xml
dev-ada/xmlada/xmlada-2017.ebuild

index 521d595c3ffba9ae860f885ae4d322c78cbe9529..6a0e93a661fe1e639946fdc68c71a8b350d40b2b 100644 (file)
@@ -6,15 +6,22 @@
                <name>Tupone Alfredo</name>
        </maintainer>
        <use>
+               <flag name="gnat_2016">Compile with dev-lang/gnat-gpl-2016</flag>
+               <flag name="gnat_2017">Compile with dev-lang/gnat-gpl-2017</flag>
                <flag name="shared">Build shared library</flag>
                <flag name="static">Build static library</flag>
                <flag name="static-pic">Build static library with pic code</flag>
        </use>
        <longdescription lang="en">
-                XML/Ada is a set of modules that provide a simple manipulation of XML streams. It supports the whole XML 1.1 specifications, and can parse any file that follows this standard (including the contents of the DTD, although no validation of the document is done based on those).
+               XML/Ada is a set of modules that provide a simple manipulation of XML
+               streams. It supports the whole XML 1.1 specifications, and can parse
+               any file that follows this standard (including the contents of the DTD,
+               although no validation of the document is done based on those).
 
-                It also provides support for a number of other standard associated with XML, like SAX, DOM and XML schemas.
+               It also provides support for a number of other standard associated
+               with XML, like SAX, DOM and XML schemas.
 
-                In addition, it includes a module to manipulate Unicode streams, since this is required by the XML standard.
+               In addition, it includes a module to manipulate Unicode streams, since
+               this is required by the XML standard.
        </longdescription>
 </pkgmetadata>
index 08f0beb233e58d6a9ff6774a6ac47ef80d95205f..b7d4d8f03d5c8bc911c90d660881a940d1c70703 100644 (file)
@@ -15,12 +15,14 @@ SRC_URI="http://mirrors.cdn.adacore.com/art/591aeb88c7a4473fcbb154f8 ->
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE="+shared static static-pic"
-REQUIRED_USE="|| ( shared static static-pic )"
+IUSE="gnat_2016 gnat_2017 +shared static static-pic"
+REQUIRED_USE="|| ( shared static static-pic )
+       ^^ ( gnat_2016 gnat_2017 )"
 
-RDEPEND="dev-lang/gnat-gpl:*"
+RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
+       gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )"
 DEPEND="${RDEPEND}
-       dev-ada/gprbuild"
+       dev-ada/gprbuild[gnat_2016=,gnat_2017=]"
 
 S="${WORKDIR}"/${MYP}-src