virtual/opencl: pull in dev-libs/beignet again for now
authorMarek Szuba <marecki@gentoo.org>
Tue, 25 Feb 2020 09:03:58 +0000 (10:03 +0100)
committerMarek Szuba <marecki@gentoo.org>
Tue, 25 Feb 2020 09:06:32 +0000 (10:06 +0100)
The fact that Beignet is the only Intel OpenCL provider supporting the
32-bit x86 ABI causes problems when it is removed from virtual/opencl.
Have to think of an exit strategy for once beignet has actually been
removed, in the meantime just have virtual/opencl use it again.

This reverts commit cdb150723eded0c5d2c8fbaaf3246ccb5b6690bc.

Bug: https://bugs.gentoo.org/710724

Signed-off-by: Marek Szuba <marecki@gentoo.org>
virtual/opencl/opencl-2.ebuild

index 736c52bcc8b09fc534c2822ccc14dacd05993069..81e5238f3c1422bbb49809681b6b0b47a427f13e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -14,9 +14,9 @@ IUSE="${CARDS[@]/#/video_cards_}"
 # intel-neo and intel-ocl-sdk are amd64-only
 RDEPEND="app-eselect/eselect-opencl
        || (
-               video_cards_i965? (
+               video_cards_i965? ( || (
                        abi_x86_64? ( !abi_x86_32? ( dev-libs/intel-neo ) )
-               )
+                       dev-libs/beignet ) )
                >=media-libs/mesa-9.1.6[opencl,X(+),${MULTILIB_USEDEP}]
                video_cards_amdgpu? ( || (
                        dev-libs/rocm-opencl-runtime