dev-python/lxml: Bump to 4.5.1
authorMichał Górny <mgorny@gentoo.org>
Wed, 20 May 2020 05:28:56 +0000 (07:28 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 20 May 2020 07:17:58 +0000 (09:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lxml/Manifest
dev-python/lxml/lxml-4.5.1.ebuild [new file with mode: 0644]

index 8355aef85e51cd58a187804363333546c91a45e0..12b46204a577abf42a0b9fcaa8c19c49d9b0bffd 100644 (file)
@@ -1 +1,2 @@
 DIST lxml-4.5.0.tar.gz 942013 BLAKE2B 24535fb74c58baff26c47c4bfe4ade0155044b30d099f1990c11406eca34e6bb8255631e5b30172adcf95fc61d1ab9d0384dbf9910c7694beed11cbb99595008 SHA512 b4b4692cffb7b8d074e72033711e17df2529d0747c4d086926855bb5a39478e7aea2bc195d201ca3c252822b231dbe47aaedc647e50bbd6b24754668beaa60ca
+DIST lxml-4.5.1.tar.gz 942377 BLAKE2B 3b7434b50d7f81628f17adf0c65e38c826304674495160a216c3051d86ddd9924f2854cf35453ba8270ca461c4c5429698a002853642f9e52206de1443c6b6f0 SHA512 0f16cdcb8aa7f8c98d3fb625d6713b422c14f0d4e7348cda38eb0776f0cfa637faaabc14dc63f8052f2741c908de6f71cfcb6471d5286c09780816b46cbfb439
diff --git a/dev-python/lxml/lxml-4.5.1.ebuild b/dev-python/lxml/lxml-4.5.1.ebuild
new file mode 100644 (file)
index 0000000..34a5acd
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1 eutils toolchain-funcs
+
+DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
+HOMEPAGE="https://lxml.de/ https://pypi.org/project/lxml/ https://github.com/lxml/lxml"
+SRC_URI="https://github.com/lxml/lxml/archive/${P}.tar.gz"
+S=${WORKDIR}/lxml-${P}
+
+LICENSE="BSD ElementTree GPL-2 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples +threads test"
+RESTRICT="!test? ( test )"
+
+# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
+RDEPEND="
+       >=dev-libs/libxml2-2.9.5
+       >=dev-libs/libxslt-1.1.28"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
+       "
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.5.0-tests-pypy.patch
+)
+
+python_prepare_all() {
+       # avoid replacing PYTHONPATH in tests.
+       sed -i -e '/sys\.path/d' test.py || die
+
+       # don't use some random SDK on Darwin
+       sed -i -e '/_ldflags =/s/=.*isysroot.*darwin.*None/= None/' \
+               setupinfo.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile() {
+       if ! python_is_python3; then
+               local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+       fi
+       tc-export PKG_CONFIG
+       distutils-r1_python_compile
+}
+
+python_test() {
+       cp -r -l src/lxml/tests "${BUILD_DIR}"/lib/lxml/ || die
+       cp -r -l src/lxml/html/tests "${BUILD_DIR}"/lib/lxml/html/ || die
+       ln -s "${S}"/doc "${BUILD_DIR}"/ || die
+
+       "${EPYTHON}" test.py -vv --all-levels -p || die "Test ${test} fails with ${EPYTHON}"
+}
+
+python_install_all() {
+       if use doc; then
+               local DOCS=( README.rst *.txt doc/*.txt )
+               local HTML_DOCS=( doc/html/. )
+       fi
+       if use examples; then
+               dodoc -r samples
+       fi
+
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       optfeature "Support for BeautifulSoup as a parser backend" dev-python/beautifulsoup
+       optfeature "Translates CSS selectors to XPath 1.0 expressions" dev-python/cssselect
+}