media-sound/qsampler-9999: fixed call of xdg functions
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 13 Dec 2019 11:47:14 +0000 (12:47 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 13 Dec 2019 11:47:14 +0000 (12:47 +0100)
for some reason they are not called automagically
so calling them manually

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/qsampler/qsampler-9999.ebuild

index 097079ef9d916d5649b7ae83d67e794e89f857d5..6e1f0a1909e742edebcf47637800055b0c7e4b7c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit qmake-utils autotools xdg subversion
+inherit qmake-utils xdg autotools subversion
 
 DESCRIPTION="Graphical frontend to the LinuxSampler engine"
 HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
@@ -53,3 +53,18 @@ src_configure() {
        cd src || die
        eqmake5 src.pro -o Makefile
 }
+
+pkg_postinst() {
+       # these are not run automagically in live ebuild for some reason so running them manually
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       # these are not run automagically in live ebuild for some reason so running them manually
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+