sys-cluster/swift: 2.25.0 and 2020.1.9999 usurri bump
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 23 Apr 2020 19:36:08 +0000 (14:36 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 23 Apr 2020 19:36:37 +0000 (14:36 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-cluster/swift/Manifest
sys-cluster/swift/swift-2.25.0.ebuild [new file with mode: 0644]
sys-cluster/swift/swift-2020.1.9999.ebuild [new file with mode: 0644]

index cf21dc9fb82a68df1a0a0fb4846e1ff3198aacbc..5f23333459d37ffcd708bbe4e8a6c5fd757694f1 100644 (file)
@@ -1,2 +1,3 @@
 DIST swift-2.23.1.tar.gz 3044545 BLAKE2B b3b06aefa7c58b718f7d9c1c1b9bc92f442b83202b8d5c2dbbb777650088f2d939f5e9d0fbe83cea38fd6635d072cd8bb3894d64ed9767dde203064c1b81cfdb SHA512 48aa82b178f5e3901363c2b9eeeedeea12a58b1ba86cc46937dd9ec074ecc005b04a6ce732d4e9fce2497c6c62b659038da40ed43550256584bb371df4e596fb
 DIST swift-2.24.0.tar.gz 3177018 BLAKE2B f465f0e8f58cc097b5b1fdbe5c9736ee3e2247d13d8ae1beeb7e736dd1246e7d8820cb7241afb67e651ad85c269a48d9dbeda3479dadd773bfc1fe3278731afe SHA512 f8e3b0fec06776e095067b2c12f782a9a787c814cea8039ec32930c562be5c74b4b2bf4cb9dad3481953e5163bd051fe32f3074be7776fd1af0be94982d113b6
+DIST swift-2.25.0.tar.gz 3183764 BLAKE2B 865cfcc832edb1f30a4529b0ff550c987a7413c841b9f1ef0d0a145f5be55762963b32ea332aa6f51690a871124e84dc7fb036309f38d4120a1e095e60bfaa34 SHA512 60cbc4bae61bb287e93d9a6a4e9a58a9c97f407d07927dde99c923d1ee7ab4ef79350c7c0cdcaab8aa0944aee09c27da549f3ebf86eb9bb92766b2b301d593a2
diff --git a/sys-cluster/swift/swift-2.25.0.ebuild b/sys-cluster/swift/swift-2.25.0.ebuild
new file mode 100644 (file)
index 0000000..94ae101
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+if [[ ${PV} == *9999 ]];then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/openstack/swift.git"
+       EGIT_BRANCH="stable/ussuri"
+else
+       SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="account container doc +memcached +object proxy"
+REQUIRED_USE="|| ( proxy account container object )"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
+       >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+       >=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
+       !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
+       !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
+       >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       dev-python/pyxattr[${PYTHON_USEDEP}]
+       >=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
+       memcached? ( net-misc/memcached )
+       net-misc/rsync[xattr]
+       acct-user/swift
+       acct-group/swift"
+
+pkg_pretend() {
+       linux-info_pkg_setup
+       CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
+       ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
+       ~ZFS"
+       if linux_config_exists; then
+               for module in ${CONFIG_CHECK}; do
+                       linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+               done
+       fi
+}
+
+src_prepare() {
+       sed -i 's/xattr/pyxattr/g' requirements.txt || die
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+src_test() {
+       # https://bugs.launchpad.net/swift/+bug/1249727
+       find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
+       SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       keepdir /etc/swift
+       insinto /etc/swift
+
+       newins "etc/swift.conf-sample" "swift.conf"
+       newins "etc/rsyncd.conf-sample" "rsyncd.conf"
+       newins "etc/mime.types-sample" "mime.types-sample"
+       newins "etc/memcache.conf-sample" "memcache.conf-sample"
+       newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
+       newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
+
+       if use proxy; then
+               newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
+               newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+               if use memcached; then
+                       sed -i '/depend/a\    need memcached' "${D}/etc/init.d/swift-proxy"
+               fi
+       fi
+       if use account; then
+               newinitd "${FILESDIR}/swift-account.initd" "swift-account"
+               newins "etc/account-server.conf-sample" "account-server.conf"
+       fi
+       if use container; then
+               newinitd "${FILESDIR}/swift-container.initd" "swift-container"
+               newins "etc/container-server.conf-sample" "container-server.conf"
+       fi
+       if use object; then
+               newinitd "${FILESDIR}/swift-object.initd" "swift-object"
+               newins "etc/object-server.conf-sample" "object-server.conf"
+               newins "etc/object-expirer.conf-sample" "object-expirer.conf"
+       fi
+
+       if use doc; then
+               doman doc/manpages/*
+               dodoc -r doc/{s3api,saio,source}
+       fi
+
+       fowners root:swift "/etc/swift"
+       fperms 0750 /etc/swift
+}
+
+pkg_postinst() {
+       elog "Openstack swift will default to using insecure http unless a"
+       elog "certificate is created in /etc/swift/cert.crt and the associated key"
+       elog "in /etc/swift/cert.key.  These can be created with the following:"
+       elog "  * cd /etc/swift"
+       elog "  * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
+}
diff --git a/sys-cluster/swift/swift-2020.1.9999.ebuild b/sys-cluster/swift/swift-2020.1.9999.ebuild
new file mode 100644 (file)
index 0000000..94ae101
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+if [[ ${PV} == *9999 ]];then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/openstack/swift.git"
+       EGIT_BRANCH="stable/ussuri"
+else
+       SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="account container doc +memcached +object proxy"
+REQUIRED_USE="|| ( proxy account container object )"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
+       >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+       >=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
+       !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
+       !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
+       >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       dev-python/pyxattr[${PYTHON_USEDEP}]
+       >=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
+       memcached? ( net-misc/memcached )
+       net-misc/rsync[xattr]
+       acct-user/swift
+       acct-group/swift"
+
+pkg_pretend() {
+       linux-info_pkg_setup
+       CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
+       ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
+       ~ZFS"
+       if linux_config_exists; then
+               for module in ${CONFIG_CHECK}; do
+                       linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+               done
+       fi
+}
+
+src_prepare() {
+       sed -i 's/xattr/pyxattr/g' requirements.txt || die
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+src_test() {
+       # https://bugs.launchpad.net/swift/+bug/1249727
+       find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
+       SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       keepdir /etc/swift
+       insinto /etc/swift
+
+       newins "etc/swift.conf-sample" "swift.conf"
+       newins "etc/rsyncd.conf-sample" "rsyncd.conf"
+       newins "etc/mime.types-sample" "mime.types-sample"
+       newins "etc/memcache.conf-sample" "memcache.conf-sample"
+       newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
+       newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
+
+       if use proxy; then
+               newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
+               newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+               if use memcached; then
+                       sed -i '/depend/a\    need memcached' "${D}/etc/init.d/swift-proxy"
+               fi
+       fi
+       if use account; then
+               newinitd "${FILESDIR}/swift-account.initd" "swift-account"
+               newins "etc/account-server.conf-sample" "account-server.conf"
+       fi
+       if use container; then
+               newinitd "${FILESDIR}/swift-container.initd" "swift-container"
+               newins "etc/container-server.conf-sample" "container-server.conf"
+       fi
+       if use object; then
+               newinitd "${FILESDIR}/swift-object.initd" "swift-object"
+               newins "etc/object-server.conf-sample" "object-server.conf"
+               newins "etc/object-expirer.conf-sample" "object-expirer.conf"
+       fi
+
+       if use doc; then
+               doman doc/manpages/*
+               dodoc -r doc/{s3api,saio,source}
+       fi
+
+       fowners root:swift "/etc/swift"
+       fperms 0750 /etc/swift
+}
+
+pkg_postinst() {
+       elog "Openstack swift will default to using insecure http unless a"
+       elog "certificate is created in /etc/swift/cert.crt and the associated key"
+       elog "in /etc/swift/cert.key.  These can be created with the following:"
+       elog "  * cd /etc/swift"
+       elog "  * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
+}