dev-haskell/yesod-auth-hashdb: bump up to 1.5.1
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 11 May 2016 07:18:19 +0000 (08:18 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 11 May 2016 08:48:03 +0000 (09:48 +0100)
Package-Manager: portage-2.2.28

dev-haskell/yesod-auth-hashdb/Manifest
dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.5.1.ebuild [new file with mode: 0644]

index 13820bc7d319ec9e832642ded2b9d2df2fd11d36..213aed1717a75fcf8165acabcc78173102a8141e 100644 (file)
@@ -1,2 +1,3 @@
 DIST yesod-auth-hashdb-1.3.0.1.tar.gz 6772 SHA256 984c38923340cd59b87f0862024cb5a9c02a84184093f2d52760999700afe860 SHA512 51bf15517055ff9929f4c633e22e1a17102a0ee06b2111ea1b4541ae013234ea41668599ae816c993ca1237b3aabe9c278d3e161504af5a2ead84c1bf2b9b26b WHIRLPOOL d06e85d1db995aad2c3b7290696819f6ee84eb71e807fed0eea2325c217f81f2d527c6ba64d88bc12224f14713a4f8d15a19edb615820a4f6b3a3da636723ccc
 DIST yesod-auth-hashdb-1.4.2.2.tar.gz 10290 SHA256 d904933fa5172cc330785591eb92fa61a3cb86599c617ff4bdedf348ecad5868 SHA512 f0a87e93dcd36887a1cc214024267c25b8d9721c44c3b9147205b22c27e663dced3482e81f35cd8685bb95c47c44ec8631adf7929f22605571570e8b3a2e862d WHIRLPOOL 96c12ba1c25435335f12f025372d97d721fd78028225111a7c33e47064809cbbda965540040c00d3652e626589824ee63b2e8095b0eab6a85f5b2c3ec0576574
+DIST yesod-auth-hashdb-1.5.1.tar.gz 12987 SHA256 fb69116768ae46b0ba582e91151438fd9f89daf0fbcfb5fc534058798552d2fe SHA512 9fbbd5b3b8bdd56e0e35a7609408fff034ba320e8271655ae29d75b1a75dd7c4ef9cebc4f94ed991137940d8161ec8560af6bf3c397d86de78e447adaf741ccf WHIRLPOOL e8bf1ccd36d55da08abdba4ec14f326345732ef13a30781d66fde584e3f84648e2f8f81e103e366f1b1c1bb8a4fe390cc5272d18a65e3db59eb9fdb768af6b5b
diff --git a/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.5.1.ebuild b/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.5.1.ebuild
new file mode 100644 (file)
index 0000000..e51decd
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication plugin for Yesod"
+HOMEPAGE="https://github.com/paul-rouse/yesod-auth-hashdb"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cryptohash-0.8:=[profile?]
+       >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.6:=[profile?]
+       >=dev-haskell/pwstore-fast-2.2:=[profile?]
+       >=dev-haskell/text-0.7:=[profile?]
+       >=dev-haskell/yesod-auth-1.4:=[profile?] <dev-haskell/yesod-auth-1.5:=[profile?]
+       >=dev-haskell/yesod-core-1.4:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+       >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
+       >=dev-haskell/yesod-persistent-1.2:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.8.0
+       test? ( dev-haskell/classy-prelude
+               >=dev-haskell/hspec-2.0.0
+               dev-haskell/http-conduit
+               dev-haskell/http-types
+               dev-haskell/monad-logger
+               dev-haskell/network-uri
+               dev-haskell/persistent-sqlite
+               dev-haskell/resourcet
+               dev-haskell/wai-extra
+               dev-haskell/yesod
+               >=dev-haskell/yesod-test-1.4.3 )
+"