dev-libs/libmowgli: Bump to EAPI=6
authorcharIes17 <charles17@arcor.de>
Thu, 11 Jan 2018 23:30:38 +0000 (00:30 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 13 Jan 2018 22:53:12 +0000 (23:53 +0100)
Bug: https://bugs.gentoo.org/644264
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Closes: https://github.com/gentoo/gentoo/pull/6835

dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild [new file with mode: 0644]
dev-libs/libmowgli/libmowgli-9999.ebuild

diff --git a/dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild b/dev-libs/libmowgli/libmowgli-1.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..f6bf87c
--- /dev/null
@@ -0,0 +1,15 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
+HOMEPAGE="http://atheme.org/projects/libmowgli.html"
+SRC_URI="http://distfiles.atheme.org/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DOCS=( AUTHORS README doc/BOOST )
index 5450f37c16c59f00444c181fc7b6d9d0797d3650..bae567fb341c767e14fe7f3b75787cf48d9c4d3c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -6,18 +6,21 @@ EAPI=6
 inherit git-r3
 
 DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
-HOMEPAGE="http://atheme.org/projects/libmowgli.html"
+HOMEPAGE="https://github.com/atheme/libmowgli-2"
 EGIT_REPO_URI="https://github.com/atheme/libmowgli-2.git"
-IUSE="libressl ssl"
 
 LICENSE="BSD-2"
 SLOT="2"
 KEYWORDS=""
-RDEPEND="ssl? (
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-)"
+IUSE="libressl ssl"
+
+RDEPEND="
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )"
 DEPEND="${RDEPEND}"
+
 DOCS=( AUTHORS README doc/BOOST doc/design-concepts.txt )
 
 src_configure() {