dev-python/webob: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 11:45:35 +0000 (13:45 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 11:50:50 +0000 (13:50 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/webob/Manifest
dev-python/webob/webob-1.8.2-r1.ebuild [deleted file]
dev-python/webob/webob-1.8.2.ebuild [deleted file]
dev-python/webob/webob-1.8.5-r1.ebuild [deleted file]
dev-python/webob/webob-1.8.5.ebuild [deleted file]

index 20deaf84bcb4527f5edf03f48fbaff610c9670fc..3d90bdb395911f635ec0c4c0b71d7e9cf05a082c 100644 (file)
@@ -1,2 +1 @@
-DIST WebOb-1.8.2.tar.gz 271737 BLAKE2B c6eef650e9b03c83d7c618d0187ef7fbd3432d043ab27501cf8c4d6dc3889f3b542c54bf35963d8a313d62246183373c30706bcf5fd00495808e21d3dc9e0482 SHA512 691a6cfbbff376e7b1f71adcaac4dbe8cc26cb4ddc396e2ab946ddf15b34c05c638113f48ee396d4edaf6ef77498ca8539d1c63de9f58894afb0e4b88bbf04ae
 DIST WebOb-1.8.5.tar.gz 271955 BLAKE2B e1d22e91e8e04c88d6adcb4dcad93e1e0c37b5b3894eee7c2b5a92d2eea41719d3b42e05916bb355a3ac9a2f7357fe791ce6f776261bfc764eadf59d4be37bad SHA512 cc0b956a7c3b8ae58d6002baf5c6de4e442201280468f8fc8b5fbd2c7f7cb7a8f46447f97b98a32a9959c8d1aa7a2a8a7b9d624cb27ca79b2ad1ce94f891801b
diff --git a/dev-python/webob/webob-1.8.2-r1.ebuild b/dev-python/webob/webob-1.8.2-r1.ebuild
deleted file mode 100644 (file)
index 5f8a233..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="https://webob.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-       fi
-}
-
-python_test() {
-       nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/webob/webob-1.8.2.ebuild b/dev-python/webob/webob-1.8.2.ebuild
deleted file mode 100644 (file)
index c72fb0e..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="https://webob.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-       fi
-}
-
-python_test() {
-       nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/webob/webob-1.8.5-r1.ebuild b/dev-python/webob/webob-1.8.5-r1.ebuild
deleted file mode 100644 (file)
index 939aac3..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="https://webob.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               >=dev-python/sphinx-1.7.5[${PYTHON_USEDEP}]
-               dev-python/alabaster[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
-       )
-"
-
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-               HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       fi
-}
-
-python_test() {
-       pytest -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/webob/webob-1.8.5.ebuild b/dev-python/webob/webob-1.8.5.ebuild
deleted file mode 100644 (file)
index 7c5945c..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="https://webob.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-       fi
-}
-
-python_test() {
-       nosetests --verbose -w tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       distutils-r1_python_install_all
-}