dev-python/aiodns: Bump to 1.2.0, py3.7, EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 13:42:19 +0000 (15:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 15 Jul 2019 13:42:19 +0000 (15:42 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/aiodns/Manifest
dev-python/aiodns/aiodns-1.2.0.ebuild [new file with mode: 0644]

index a64ae169c5c1947a75ed37533fc96b5ab22b9fd9..300d641b6e0e819558e43c5ee05480a3e5d6ca7d 100644 (file)
@@ -1 +1,2 @@
 DIST aiodns-1.1.1.tar.gz 6084 BLAKE2B 8e58cedcf288f87ca9cc8d5f067bdf182f220979aba3d2aa53eb998ae877dcaa7c2a7419a50719ba150fdf17271d025668b28a3212fc5a819bf13129b4fb25a2 SHA512 4bd8b80a10f84b82b13ba4ff6abbb1afd13ba6cfececc4db7c4bd303569473316f1c0e083f1017a450875fc8994a70c30c9a1b3fb2278fee5e27158973bc3810
+DIST aiodns-1.2.0.tar.gz 6457 BLAKE2B c1035e5a31b179665be1c7c75e3e8f6665e04c43d5f2bada7e0d7ef76f17d99d2d86c2bd5063fbda2d2947c7a4aa1e21e66cef070019da6bf56e94d716edc0ea SHA512 2e80c275d98f54378b121cafe4680221f29eb57346976b3c476c7110fcb215892744982de25736193663ab4ac3f3cf516fa38b664e3303e6c67180ed6c31e21b
diff --git a/dev-python/aiodns/aiodns-1.2.0.ebuild b/dev-python/aiodns/aiodns-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..3f37662
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+$(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' -2)"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       "${EPYTHON}" tests.py -v || die
+}