bug 123964, large file support
authorAlec Warner <antarus@gentoo.org>
Thu, 25 Jan 2007 07:08:57 +0000 (07:08 +0000)
committerAlec Warner <antarus@gentoo.org>
Thu, 25 Jan 2007 07:08:57 +0000 (07:08 +0000)
Package-Manager: portage-2.1.1-r2

net-misc/fmirror/ChangeLog
net-misc/fmirror/files/digest-fmirror-0.8.4
net-misc/fmirror/files/digest-fmirror-0.8.4-r2 [new file with mode: 0644]
net-misc/fmirror/fmirror-0.8.4-r2.ebuild [new file with mode: 0644]

index 6b82d1ce92a176837e9ca1297c471e579235c48f..98086790460b98ab9c50f61b12879217dd61f2ba 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/fmirror
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/fmirror/ChangeLog,v 1.7 2005/05/10 10:21:00 dholm Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fmirror/ChangeLog,v 1.8 2007/01/25 07:08:57 antarus Exp $
+
+*fmirror-0.8.4-r2 (25 Jan 2007)
+
+  25 Jan 2007; Alec Warner <antarus@gentoo.org>+fmirror-0.8.4-r2.ebuild,
+  -fmirror-0.8.4-r1.ebuild:
+  bug 123964, large file support
 
   10 May 2005; David Holm <dholm@gentoo.org> fmirror-0.8.4-r1.ebuild:
   Added to ~ppc.
index f71eabad15dbf40b0f2825a88b947a09a35f1f2e..ace52127f5a63c049193ec4b8773dce86a4167ae 100644 (file)
@@ -1 +1,3 @@
 MD5 78652ce5bb50e6c120c9ca0988cb9dca fmirror-0.8.4.tar.gz 59831
+RMD160 f053b0d7f88d516890263e7b65e63a781dd2f044 fmirror-0.8.4.tar.gz 59831
+SHA256 d280e496a2b6dedbd6fda635a80486dbc1462e7c09dbd950962b6742f927dae4 fmirror-0.8.4.tar.gz 59831
diff --git a/net-misc/fmirror/files/digest-fmirror-0.8.4-r2 b/net-misc/fmirror/files/digest-fmirror-0.8.4-r2
new file mode 100644 (file)
index 0000000..ace5212
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 78652ce5bb50e6c120c9ca0988cb9dca fmirror-0.8.4.tar.gz 59831
+RMD160 f053b0d7f88d516890263e7b65e63a781dd2f044 fmirror-0.8.4.tar.gz 59831
+SHA256 d280e496a2b6dedbd6fda635a80486dbc1462e7c09dbd950962b6742f927dae4 fmirror-0.8.4.tar.gz 59831
diff --git a/net-misc/fmirror/fmirror-0.8.4-r2.ebuild b/net-misc/fmirror/fmirror-0.8.4-r2.ebuild
new file mode 100644 (file)
index 0000000..c28560d
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fmirror/fmirror-0.8.4-r2.ebuild,v 1.1 2007/01/25 07:08:57 antarus Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="FTP mirror utility"
+HOMEPAGE="http://freshmeat.net/projects/fmirror"
+SRC_URI="ftp://ftp.guardian.no/pub/free/ftp/fmirror/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_unpack() {
+       unpack ${A}; cd ${S}
+       epatch ${FILESDIR}/${PN}-crlf.patch
+}
+
+src_compile() {
+       append-flags "-D_FILE_OFFSET_BITS=64" # large file support bug # 123964
+       econf \
+               --datadir=/etc/fmirror \
+       || die "configure problem"
+
+       emake || die "compile problem"
+}
+
+src_install() {
+       into /usr
+       dobin fmirror
+       dodoc COPYING ChangeLog README
+       newdoc configs/README README.sample
+       doman fmirror.1
+
+       cd configs
+       insinto /etc/fmirror/sample
+       doins {sample,generic,redhat}.conf
+}