dev-perl/libintl-perl: Bump to version 1.310.0
authorKent Fredric <kentnl@gentoo.org>
Mon, 15 Jul 2019 10:31:14 +0000 (22:31 +1200)
committerKent Fredric <kentnl@gentoo.org>
Mon, 15 Jul 2019 10:31:56 +0000 (22:31 +1200)
- Add USE=examples and USE=minimal
- Add missing dependencies

Upstream:
- Fix broken inability to load .mo files with a revision of 0.1
- Disable utf8 when doing locale lookups
- Disable failing de_AT related test
- Avoid excessive calls to stat() on previously ENOENT'd .mo files.

Keywords:
- Dropped due to File::ShareDir dependency:
   {amd64,x86}-fbsd, riscv x64-cygwin

Bug: https://github.com/gflohr/libintl-perl/issues/3
Bug: https://bugs.gentoo.org/661768
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/libintl-perl/Manifest
dev-perl/libintl-perl/libintl-perl-1.310.0.ebuild [new file with mode: 0644]

index f301751a51c02dae552767d42172082db24e4afc..4c9c2c5db8a2b045cf6a719d5ba5a9a260631d6e 100644 (file)
@@ -1,2 +1,3 @@
 DIST libintl-perl-1.24.tar.gz 605626 BLAKE2B 6949f895ba54853704d5470e8a736e799d74ddbd569378254ac19ada9cc43c644f78bea1949b7a4c0072d4fe54f0744b7ad011539c6a1dd1191c6792c9347f1a SHA512 1c2c5d6d7ab21c45897195952a9f0f6ba26a9bbb7bfef0b5f3e9da282fcf94ab4ee80721164e5e3293d8abda0158e77ffbc331b8bed66aa56dd7fc7a6a91323d
 DIST libintl-perl-1.28.tar.gz 470898 BLAKE2B 6217a37f2176869dc945bd64a87a82710645153e3777fb5e4ddc674f179040d2268f326411a578314efafaa0edbd0e67aed99c4da86e20e811e1116d5cf2a86a SHA512 50f0836c1a84a22fcc8fca0fff2faeaae66774ec67b96c09a911c4969e8a610bbf20ba38167c13339b9ad9617e1fca07cb0cb1f12732f973b1cf618d502f59aa
+DIST libintl-perl-1.31.tar.gz 598187 BLAKE2B 6ce30e51cb001993d6ee3727c69010a3d8d9014334df8749704760734486e50296cdf019e185b463d4ccb3aac660526b440d4217aa5b304f749c5ecf43d18ca3 SHA512 9e22af95ecb8ae1c115114ce5d4f80bb8b1a83e4072d274a55f5946267ac29b98e9da4c01e05d0aa0051fef34a41b6297dbb44f51b8d602f3ef3786a59a6a04a
diff --git a/dev-perl/libintl-perl/libintl-perl-1.310.0.ebuild b/dev-perl/libintl-perl/libintl-perl-1.310.0.ebuild
new file mode 100644 (file)
index 0000000..3c34519
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GUIDO
+DIST_VERSION=1.31
+DIST_EXAMPLES=("sample/*")
+inherit perl-module
+
+DESCRIPTION="High-Level Interface to Uniforum Message Translation"
+HOMEPAGE="http://guido-flohr.net/projects/libintl-perl ${HOMEPAGE}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal"
+
+RDEPEND="
+       virtual/libintl
+       !minimal? (
+               dev-perl/File-ShareDir
+       )
+       virtual/perl-File-Spec
+       >=virtual/perl-version-0.770.0
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.280.0-sanity-2.patch" )