sys-apps/dmapi: fix build w/newer glibc #560212
authorMike Frysinger <vapier@gentoo.org>
Sat, 12 Sep 2015 03:47:59 +0000 (23:47 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 12 Sep 2015 03:47:59 +0000 (23:47 -0400)
As glibc cleans up its headers to not implicitly include things, packages
like dmapi break a little as they don't include headers they need.

sys-apps/dmapi/dmapi-2.2.12-r1.ebuild
sys-apps/dmapi/files/dmapi-2.2.12-headers.patch [new file with mode: 0644]

index 54291171b34aceaac7adabeb979f32cda78bd2f2..8c8af810c53a7e419b69322f79972009b56549b3 100644 (file)
@@ -24,6 +24,7 @@ src_prepare() {
                -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
                include/builddefs.in \
                || die
+       epatch "${FILESDIR}"/${P}-headers.patch
 
        multilib_copy_sources
 }
diff --git a/sys-apps/dmapi/files/dmapi-2.2.12-headers.patch b/sys-apps/dmapi/files/dmapi-2.2.12-headers.patch
new file mode 100644 (file)
index 0000000..259e1ae
--- /dev/null
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/560212
+
+pull in headers for funcs that are used
+
+--- a/libdm/dm_handle2path.c
++++ b/libdm/dm_handle2path.c
+@@ -20,6 +20,9 @@
+ #include <dmapi_kern.h>
+ #include "dmapi_lib.h"
++#include <fcntl.h> /* open */
++#include <unistd.h> /* close */
++#include <string.h> /* strlen */
+ #include <mntent.h>
+ #include <dirent.h>
+ #ifdef linux