dev-python/sshtunnel: Bump to 0.1.5
authorAaron W. Swenson <titanofold@gentoo.org>
Wed, 25 Mar 2020 12:43:17 +0000 (08:43 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Wed, 25 Mar 2020 12:43:21 +0000 (08:43 -0400)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-python/sshtunnel/Manifest
dev-python/sshtunnel/sshtunnel-0.1.5.ebuild [new file with mode: 0644]

index a5b9b6e492b28c1a0322152305c58353c7bab764..0f0208aa5d1b96e52bad0bc4975b70aabd86bffc 100644 (file)
@@ -1 +1,2 @@
 DIST sshtunnel-0.1.4.tar.gz 48330 BLAKE2B 5fdc5dd602274a16025f250fcc3a36453a17c921f51367cac0cb0ef36be6251f687b53b1df6072d1e32456a5c0fa5ec6d2fd8e5d4874977a641a6c9ba81ac57c SHA512 c228fe79cf5172c950777a40b27ababd42a31b7aad8a8472d55a2b3babf5aa4c5308799bb271f33f0e943c309eb9adedee321045a03324cb5e30a385178751ca
+DIST sshtunnel-0.1.5.tar.gz 49345 BLAKE2B dde497296ebf84cd34a485ac82de3ca138671b4b8ad2d2307a5e40dc0bb9c6a6daa8c8f3888db942133a9a0fb5321c240c5f2db7c93baf824c9cefaf361ef7c9 SHA512 ae804865a83bae8443cff1a73b168ffb8aac0c5c4fa6c7a5e142f4f95b4eef34bc7674588fa8797fa35b2685016828bcb137f4102e84ea15089671cf64503d17
diff --git a/dev-python/sshtunnel/sshtunnel-0.1.5.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.5.ebuild
new file mode 100644 (file)
index 0000000..b20a6d1
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python SSH tunnels"
+HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/tox[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests setup.py