app-editors/nano: update to EAPI=5 and use subslot w/ncurses #561310
authorMike Frysinger <vapier@gentoo.org>
Sat, 26 Sep 2015 07:25:39 +0000 (03:25 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 26 Sep 2015 08:07:42 +0000 (04:07 -0400)
Also sync the magic changes from the non-live to the 9999 ebuild.

app-editors/nano/nano-2.4.2.ebuild
app-editors/nano/nano-9999.ebuild

index f324c2e1ac7f765a27d6571fa554c6cc4f81e10b..48d87ed39596f975dd6b5eeeb2f58fa898f826a5 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI="4"
+EAPI="5"
 
 inherit eutils flag-o-matic
 if [[ ${PV} == "9999" ]] ; then
@@ -21,8 +21,8 @@ LICENSE="GPL-3"
 SLOT="0"
 IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
 
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0[unicode?]
-       sys-libs/ncurses:0[static-libs(+)]
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+       sys-libs/ncurses:0=[static-libs(+)]
        magic? ( sys-apps/file[static-libs(+)] )
        nls? ( virtual/libintl )
        !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
index 8548decc2d0ec1bd2a98920101af036be6f88316..48d87ed39596f975dd6b5eeeb2f58fa898f826a5 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI="4"
+EAPI="5"
 
 inherit eutils flag-o-matic
 if [[ ${PV} == "9999" ]] ; then
@@ -21,8 +21,8 @@ LICENSE="GPL-3"
 SLOT="0"
 IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
 
-LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0[unicode?]
-       sys-libs/ncurses:0[static-libs(+)]
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+       sys-libs/ncurses:0=[static-libs(+)]
        magic? ( sys-apps/file[static-libs(+)] )
        nls? ( virtual/libintl )
        !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
@@ -41,7 +41,6 @@ src_prepare() {
 
 src_configure() {
        use static && append-ldflags -static
-       eval export ac_cv_{header_magic_h,lib_magic_magic_open}=$(usex magic)
        local myconf=()
        case ${CHOST} in
        *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
@@ -53,6 +52,7 @@ src_configure() {
                $(use_enable !minimal multibuffer) \
                $(use_enable !minimal nanorc) \
                --disable-wrapping-as-root \
+               $(use_enable magic libmagic) \
                $(use_enable spell speller) \
                $(use_enable justify) \
                $(use_enable debug) \