version bump from upstream
authorSaleem Abdulrasool <compnerd@gentoo.org>
Tue, 2 Jan 2007 23:21:43 +0000 (23:21 +0000)
committerSaleem Abdulrasool <compnerd@gentoo.org>
Tue, 2 Jan 2007 23:21:43 +0000 (23:21 +0000)
Package-Manager: portage-2.1.2_rc4-r4

dev-util/mono-tools/ChangeLog
dev-util/mono-tools/files/digest-mono-tools-1.2.1 [new file with mode: 0644]
dev-util/mono-tools/mono-tools-1.2.1.ebuild [new file with mode: 0644]
dev-util/monodoc/ChangeLog
dev-util/monodoc/files/digest-monodoc-1.2.1 [new file with mode: 0644]
dev-util/monodoc/monodoc-1.2.1.ebuild [new file with mode: 0644]

index 950d4ea83f2244b9a026c27d0ea8338074db7e8c..d8178761a41da8e3f81382118a57ce2f81d64ef0 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-util/mono-tools
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/ChangeLog,v 1.14 2006/10/29 04:58:50 latexer Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/ChangeLog,v 1.15 2007/01/02 23:21:43 compnerd Exp $
+
+*mono-tools-1.2.1 (02 Jan 2007)
+
+  02 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+  +mono-tools-1.2.1.ebuild:
+  Version bump from upstream
 
 *mono-tools-1.1.17-r1 (28 Oct 2006)
 
diff --git a/dev-util/mono-tools/files/digest-mono-tools-1.2.1 b/dev-util/mono-tools/files/digest-mono-tools-1.2.1
new file mode 100644 (file)
index 0000000..e3240c8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d65587a842799f2e087ef101bcb4c68a mono-tools-1.2.1.tar.gz 281653
+RMD160 b96046218262220a931b074724334a31743026a1 mono-tools-1.2.1.tar.gz 281653
+SHA256 3968713b758fa80156de19339f20be102c34aadd2817f955041db8402d76be78 mono-tools-1.2.1.tar.gz 281653
diff --git a/dev-util/mono-tools/mono-tools-1.2.1.ebuild b/dev-util/mono-tools/mono-tools-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..24f8378
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-1.2.1.ebuild,v 1.1 2007/01/02 23:21:43 compnerd Exp $
+
+inherit eutils mono multilib autotools
+
+DESCRIPTION="Set of useful Mono related utilities"
+HOMEPAGE="http://www.mono-project.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtkhtml seamonkey"
+
+RDEPEND="dev-lang/mono
+                >=dev-util/monodoc-${PV}
+                =dev-dotnet/gtk-sharp-2*
+                =dev-dotnet/glade-sharp-2*
+                =dev-dotnet/gconf-sharp-2*
+                gtkhtml? ( =dev-dotnet/gtkhtml-sharp-2* )
+                seamonkey? ( =dev-dotnet/gecko-sharp-0.11* )
+                !seamonkey? ( =dev-dotnet/gtkhtml-sharp-2* )"
+DEPEND="${RDEPEND}
+               sys-devel/gettext"
+
+# Parallel build unfriendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+       if ! use gtkhtml && ! use seamonkey ; then
+               einfo "No browser selected, defaulting to gtkhtml"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       # Make the browser optional
+       epatch ${FILESDIR}/${PN}-1.1.17-html-renderer-fixes.diff
+
+       # Install all our .dlls under $(libdir), not $(prefix)/lib
+       if [ $(get_libdir) != "lib" ] ; then
+               sed -i -e 's:$(prefix)/lib:$(libdir):'                    \
+                       ${S}/{asn1view/gtk,docbrowser,gnunit/src}/Makefile.am \
+               || die "sed failed"
+
+               sed -i -e 's:$prefix/lib:@libdir@:' \
+                       ${S}/docbrowser/monodoc.in      \
+               || die "sed failed"
+       fi
+
+       eautoreconf
+}
+
+src_compile() {
+       local myconf="$(use_enable gtkhtml) $(use_enable seamonkey mozilla)"
+
+       if ! use gtktml && ! use seamonkey ; then
+               myconf="--enable-gtkhtml --disable-mozilla"
+       fi
+
+       econf ${myconf} || die "configure failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc ChangeLog README
+}
index c720c468ca971c244ec52aab7b8f44725ef670cc..8d061559bb97407a36b1ad81b0cbf4964a3b1a1f 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-util/monodoc
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/ChangeLog,v 1.51 2006/12/19 20:15:57 jurek Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/ChangeLog,v 1.52 2007/01/02 23:19:53 compnerd Exp $
+
+*monodoc-1.2.1 (02 Jan 2007)
+
+  02 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+  +monodoc-1.2.1.ebuild:
+  Version bump from upstream
 
   19 Dec 2006; Jurek Bartuszek <jurek@gentoo.org> monodoc-1.1.9.ebuild,
   monodoc-1.1.10.ebuild, monodoc-1.1.13.ebuild, monodoc-1.1.18.ebuild:
diff --git a/dev-util/monodoc/files/digest-monodoc-1.2.1 b/dev-util/monodoc/files/digest-monodoc-1.2.1
new file mode 100644 (file)
index 0000000..a9b1c7b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 19437a8652ee009364abb04b767b65ba monodoc-1.2.1.zip 13221292
+RMD160 25c54e51490fa3ae8f4d4fa1768b4a3c10983c5f monodoc-1.2.1.zip 13221292
+SHA256 0eca906773e6eac262f4f55de15ef0df93befc79bdd3beda65f6bd0c32253ed6 monodoc-1.2.1.zip 13221292
diff --git a/dev-util/monodoc/monodoc-1.2.1.ebuild b/dev-util/monodoc/monodoc-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..8645511
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/monodoc-1.2.1.ebuild,v 1.1 2007/01/02 23:19:53 compnerd Exp $
+
+inherit mono multilib
+
+DESCRIPTION="Documentation for mono's .Net class library"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+RDEPEND=">=dev-lang/mono-1.1
+               www-client/lynx"
+DEPEND="${RDEPEND}
+               app-arch/unzip"
+PDEPEND="X? ( >=dev-util/mono-tools-1.1.17 )"
+
+# Parallel build unfriendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       # Install all our .dlls under $(libdir), not $(prefix)/lib
+       if [ $(get_libdir) != "lib" ] ; then
+               sed -i -e 's:$(prefix)/lib:$(libdir):'             \
+                       ${S}/engine/Makefile.am                        \
+               || die "sed failed"
+
+               sed -i -e 's:libdir=@prefix@/lib:libdir=@libdir@:' \
+                       -i -e 's:${prefix}/lib:${libdir}:'             \
+                       ${S}/monodoc.pc.in                             \
+               || die "sed failed"
+
+               aclocal || die "aclocal failed"
+               automake || die "automake failed"
+       fi
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+}