Add use pch (as suggested by X on comment 2 of bug #167428).
authorTimothy Redaelli <drizzt@gentoo.org>
Wed, 28 Feb 2007 09:25:23 +0000 (09:25 +0000)
committerTimothy Redaelli <drizzt@gentoo.org>
Wed, 28 Feb 2007 09:25:23 +0000 (09:25 +0000)
Accept also qt with sqlite3 use (thanks to desowin wrt bug #166215).

Package-Manager: portage-2.1.2-r11

media-sound/mumble/ChangeLog
media-sound/mumble/mumble-0.9.4.ebuild

index ab8d3a8adf0cfdffa71571fd623612021069c90d..9168c1f569f026f1bb86024e727628b68dacbe6c 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-sound/mumble
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.3 2007/02/08 18:47:48 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.4 2007/02/28 09:25:23 drizzt Exp $
+
+  28 Feb 2007; Timothy Redaelli <drizzt@gentoo.org> mumble-0.9.4.ebuild:
+  Add use pch (as suggested by X on comment 2 of bug #167428).
+  Accept also qt with sqlite3 use (thanks to desowin wrt bug #166215).
 
   08 Feb 2007; Timothy Redaelli <drizzt@gentoo.org>
   -files/mumble-0.9.4-missing_typedefs.patch, mumble-0.9.4.ebuild:
index 16ae5ee1dad26a9bc55e7170b0a1f15a9b31c7db..858be32c539d198171287b41340b0a7a4b1a51cd 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-0.9.4.ebuild,v 1.3 2007/02/08 18:47:48 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-0.9.4.ebuild,v 1.4 2007/02/28 09:25:23 drizzt Exp $
 
 inherit eutils toolchain-funcs
 
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~x86 ~amd64"
-IUSE=""
+IUSE="pch"
 
 DEPEND="dev-libs/boost
        =x11-libs/qt-4*
@@ -22,9 +22,9 @@ DEPEND="dev-libs/boost
 RDEPEND="${DEPEND}"
 
 pkg_setup() {
-       if ! built_with_use =x11-libs/qt-4* sqlite ; then
+       if ! built_with_use =x11-libs/qt-4* sqlite sqlite3; then
                echo
-               ewarn "You need to build Qt4 with the sqlite use flag"
+               ewarn "You need to build Qt4 with the sqlite and/or sqlite3 use flag"
                echo
                die "Your Qt4 has no sqlite support"
        fi
@@ -34,6 +34,7 @@ src_unpack() {
        unpack ${A}
        cd "${S}"
 
+       use pch || sed -i -e '3s: precompile_header$::' mumble.pri
        epatch "${FILESDIR}"/${P}-path.patch
 }