dev-python/falcon: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:31 +0000 (09:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:31 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/falcon/Manifest
dev-python/falcon/falcon-0.1.6.ebuild [deleted file]
dev-python/falcon/falcon-0.1.7.ebuild [deleted file]
dev-python/falcon/falcon-0.1.8.ebuild [deleted file]
dev-python/falcon/falcon-0.1.9.ebuild [deleted file]

index 9cc35f4d0c083304808e2de3e83bb88aa047803e..e9ebb8c929d13ede1ff1df051c8674ea570ea27c 100644 (file)
@@ -1,5 +1 @@
-DIST falcon-0.1.6.tar.gz 186870 BLAKE2B c0c48193cca6ee516f07985810c73520dd2b554725adf16fcfb60d870ca6dd7188026a896127d185d8c2dbf9c4faad13748dd9ab9bd0951f3c2003adbe4e03d3 SHA512 033b06d643dc910d62830d42a559a1fa1933b93c8f93b136c0ba89429cf3eadd912b5512f2add2ae904c3ff192046718a8d40a53d3a05506dfc2722cf5437668
-DIST falcon-0.1.7.tar.gz 193151 BLAKE2B 35d4dc329eda806cd193525c953b011770cbb5ffdd33d52f2aded8e92dd357aa1280cfabb2107aac9e3a1a33ff26ea3d8233798a258e478405c54a9f09b0f103 SHA512 665a0bdd02c8e9a0806c863164fde33a6a10a1ac8c2ec9c3194da0ca41e411c19ec5b2a84cce521abb510588c23b4bb5fab25af58d5c17fbbf8e7c3304839b9a
-DIST falcon-0.1.8.tar.gz 202170 BLAKE2B 3857672d39138b83760bc58a869a384f7305f7938e20f801b35e5777e3028caa8500ac045101a69c32f2925000e175eefaf4a4a5ac5488aa26d41ce2cf9d9701 SHA512 e0ec028c1d1dc3fba722bd91f9bb315523367313bef40238579a96ca49de37f4c63e53746bf6ab40add053320925378860e3571e32401151c00d4afcbad9b7ca
-DIST falcon-0.1.9.tar.gz 202209 BLAKE2B 89c786fb777fda3e4118271bedc979bbb4968defe40e863464d27ca7a65ee5ab1e4c0d694625b7c96bf492fb6b8f9cba15fde686af871ec3629477bf4bfc7655 SHA512 442a04c925f4af69bb0f1906c4123e68ef423e4040fbde82cecc200a44410665c0f97ad28e7f59e4139aae1209ba1df1dd445c5a44e6b975bed9416a97e681e8
 DIST falcon-1.3.0.tar.gz 507250 BLAKE2B 3ba3a989f2e9eb281f519e36a24772fe329fee849097028f3183b0e0c7908b7e06dbf0a70ba28cf7570dccbe88fa87703c47d985ea3cf761ea7d6ec3d41ac04b SHA512 a92d0b641152f653f47c9cb9b2e368d643aae14dcabe7028450d190bd08b883d37116d23d3a1ae4e092207f15926f66b12f57e38dd2edd347f6f8df48baa65ce
diff --git a/dev-python/falcon/falcon-0.1.6.ebuild b/dev-python/falcon/falcon-0.1.6.ebuild
deleted file mode 100644 (file)
index fe4a67f..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
-       cython? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
-       nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
-       if ! use cython; then
-               sed -i -e 's/if with_cython:/if False:/' setup.py \
-                       || die 'sed failed.'
-       fi
-}
diff --git a/dev-python/falcon/falcon-0.1.7.ebuild b/dev-python/falcon/falcon-0.1.7.ebuild
deleted file mode 100644 (file)
index a1f2614..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
-       dev-python/mimeparse[${PYTHON_USEDEP}]
-       cython? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
-       nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
-       if ! use cython; then
-               sed -i -e 's/if with_cython:/if False:/' setup.py \
-                       || die 'sed failed.'
-       fi
-}
diff --git a/dev-python/falcon/falcon-0.1.8.ebuild b/dev-python/falcon/falcon-0.1.8.ebuild
deleted file mode 100644 (file)
index 4b28fa1..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
-       dev-python/mimeparse[${PYTHON_USEDEP}]
-       cython? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
-       nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
-       if ! use cython; then
-               sed -i -e 's/if with_cython:/if False:/' setup.py \
-                       || die 'sed failed.'
-       fi
-
-       # fix tests installation : potential file collision
-       sed -e 's@^where = tests@where = falcon/tests@g' -i setup.cfg || die
-       mv tests falcon/
-}
diff --git a/dev-python/falcon/falcon-0.1.9.ebuild b/dev-python/falcon/falcon-0.1.9.ebuild
deleted file mode 100644 (file)
index 613ba79..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python{2_7,3_5} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
-       dev-python/mimeparse[${PYTHON_USEDEP}]
-       cython? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})] )"
-
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/cython[$(python_gen_usedep python{2_7,3_3})]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
-       nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
-       if ! use cython; then
-               sed -i -e 's/if with_cython:/if False:/' setup.py \
-                       || die 'sed failed.'
-       fi
-
-       # fix tests installation : potential file collision
-       sed -e 's@^where = tests@where = falcon/tests@g' -i setup.cfg || die
-       mv tests falcon/
-}