dev-python/requests_pkcs12: bump to 1.7
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 9 Apr 2020 16:46:31 +0000 (09:46 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 9 Apr 2020 17:07:21 +0000 (10:07 -0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/requests_pkcs12/Manifest
dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild [new file with mode: 0644]

index 0595f75eac2dbe19d4492dbd950031aad353030d..b76bf56747f28224bea2310fac6b1de4d2e37000 100644 (file)
@@ -1 +1,2 @@
 DIST requests_pkcs12-1.4.tar.gz 3884 BLAKE2B ebeb89349163d4f9995c00dfe3d725036a76660870d36203f47029f225698fe7a15993a9dd756e0b6b33011726ad26323962609bb94f223f4478096658f20a3c SHA512 f77703b7b0ba1f13aa095fcf4955f119c34a20e0601e0d6888a29932d8d4289548cf2b7b0e065abfea2ebcda542d48a4d9a3ded32974c1d24bdae223893f0241
+DIST requests_pkcs12-1.7.tar.gz 3914 BLAKE2B f91c7d1677964cfe903b4c0f688e25b5b3b7eb921fdeb4e794cbea24ceafe4e44f7587df48c0ad56ff20114641f6897ab4ef26a64b53e6fcb7d713ecf36bb1c0 SHA512 be3fe00ef405b44d9f160ff35c072b86da511a68380e2737e9316a0d1dd89c3d8ba7adbaaf9865ca01cfbbdb85c477364780cbe3e77e2963dcd7b54519a95356
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.7.ebuild
new file mode 100644 (file)
index 0000000..3cf7001
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND=""
+
+RDEPEND="
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"