media-sound/yoshimi: bumped to the latest with ebuild changes
authorDenis Reva <denis7774@gmail.com>
Sat, 28 Mar 2020 02:27:26 +0000 (07:27 +0500)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 1 Apr 2020 09:31:37 +0000 (11:31 +0200)
Signed-off-by: Denis Reva <denis7774@gmail.com>
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/yoshimi/Manifest
media-sound/yoshimi/metadata.xml
media-sound/yoshimi/yoshimi-1.7.0.1.ebuild [new file with mode: 0644]

index 5677960a65fad53ad6d2334fbfbe4f0df87f8d66..5bffa8e4cbcef40942b4003a4b56d685a331daa7 100644 (file)
@@ -1 +1,2 @@
 DIST yoshimi-1.5.10.2.tar.gz 9668476 BLAKE2B 1b443a51e952123abaf54b992902113533461064f2fc99032ac89f28a25ba4687176a97013ea118283e8ca2b7d92f44c105380e3d6cecb66560db7a0a8ef6532 SHA512 a39ba123f304e43d70833648ce224733794cb43c160fd2e6cf29bb4a782bea355c4bbfa1c33bf20c98a8c1f5d049788154aaf906a3daa56f288719a0b019139c
+DIST yoshimi-1.7.0.1.tar.gz 9987526 BLAKE2B e1793b0515fce39a62288f61fda0028c1683080c276b451f2cc67edd617ed2d25d408d3571ac56e8a7d6a4fd537719ba517b4faef969810520fc8af3aee013de SHA512 d403ca3f54a0c8eb27a1f4ea3bf90ab0fd8041b864259c94b0970b24b50b79fc84ea623af2981a1b00e65ebdd3f9ceeb0b5f04c64f62e5694aa55b31bb8390ce
index 1b622256a8dac84795f1b65b90cb1a75bd9a7d47..5d989b377648f1e54d153c437cb814c6fa4cc7fd 100644 (file)
@@ -1,6 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
+       <maintainer type="person">
+               <email>denis7774@gmail.com</email>
+               <name>Reva Denis aka RarogCmex</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <maintainer type="project">
                <email>sound@gentoo.org</email>
                <name>Gentoo Sound project</name>
        <upstream>
                <remote-id type="github">Yoshimi/yoshimi</remote-id>
        </upstream>
+       <longdescription>
+       Yoshimi is a software audio synthesizer, originally forked from ZynAddSubFX
+       Features
+       Three separate engines
+       each with distinctive characteristics, can be used together or individually
+       Sixteen engine kits for the ultimate in multi-layering of engines, or for synthesized drum kits 
+       Vector Control
+       manage up to four independent sounds on any channel with faders or an X/Y midi joystick
+       Solo
+       step through up to 16 sounds seamlessly while playing in real time (including vector sounds)
+       Microtonal Tuning
+       Scala-compatible scales and keymaps
+       Extensive Midi-Learn
+       capture almost all internal controls and many switches with ordinary 7-bit values, or NRPNs, or even 7-bit NRPNs, then edit the responses
+       Command Line Access
+       headless operation and high accessibility, for those with sight- or motor control issues
+       Rich variations of tone and timbre
+       Yoshimi provides the means to ensure no two notes are ever identical - just like in the real world.
+       And much more...
+       </longdescription>
 </pkgmetadata>
diff --git a/media-sound/yoshimi/yoshimi-1.7.0.1.ebuild b/media-sound/yoshimi/yoshimi-1.7.0.1.ebuild
new file mode 100644 (file)
index 0000000..0f180a3
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg flag-o-matic
+
+DESCRIPTION="Software synthesizer based on ZynAddSubFX"
+HOMEPAGE="https://yoshimi.github.io/"
+SRC_URI="https://github.com/${PN^}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+lv2"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+       >=dev-libs/mxml-3.1
+       media-libs/alsa-lib
+       media-libs/fontconfig
+       media-libs/libsndfile
+       sci-libs/fftw:3.0=
+       sys-libs/ncurses:0=
+       sys-libs/readline:0=
+       sys-libs/zlib
+       virtual/jack
+       x11-libs/cairo[X]
+       x11-libs/fltk:1[opengl]
+       lv2? ( media-libs/lv2 )
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_USE_DIR="${WORKDIR}/${P}/src"
+
+DOCS=( Changelog README.txt )
+
+src_prepare() {
+       cmake-utils_src_prepare
+       append-cxxflags -lpthread
+       append-cppflags -lpthread
+}
+
+src_configure() {
+       local mycmakeargs=( -DLV2Plugin=$(usex lv2) )
+       cmake-utils_src_configure
+}
+src_install() {
+       cmake-utils_src_install
+       mv ${D}/usr/share/doc/yoshimi ${D}/usr/share/doc/${P}
+}