www-apps/phpBB: Version bump to 3.2.8
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 24 Nov 2019 23:21:39 +0000 (23:21 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 24 Nov 2019 23:21:39 +0000 (23:21 +0000)
PHP 7.3 won't be supported until phpBB 3.3.

Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
www-apps/phpBB/Manifest
www-apps/phpBB/phpBB-3.2.8.ebuild [new file with mode: 0644]

index 42c23a471f2600c173247c09d70418c06e6f0036..19c367b0b6d04bde0657aeca3f612fffe191c3c0 100644 (file)
@@ -1 +1,2 @@
 DIST phpBB-3.2.7.tar.bz2 4384851 BLAKE2B 68af960efa04a30f81869b205d9c43ace86a4a4411a4cb969cdf5d52c8bf4f87f806fc3b2c71941f15be295afe5faa0d606af72a734356c3a7f0f97fb73d3f01 SHA512 f6cf728c022d803f2b39560037b987e832f4ee4583a377f63e01a1529b58e275db4f13386a0d70b50cfb40621d7573a26e349702f901a549cedda9db7f79d4d2
+DIST phpBB-3.2.8.tar.bz2 4388929 BLAKE2B 8d7b7294a852450400f721cb05d258bb36b88c48133d340292bb2733c4a28da02e3c2038eb269e0549512cc3db286c4e31eb970070edda0493c304185bc303d0 SHA512 467a84917041889eaa7f2e68a0a81d9368f3ee36427883dec7ebd2af72fe21044dbdb08c5a068ab4e67490af2e4b30132db9d3a300382dd5ccc0a54f7ca20a31
diff --git a/www-apps/phpBB/phpBB-3.2.8.ebuild b/www-apps/phpBB/phpBB-3.2.8.ebuild
new file mode 100644 (file)
index 0000000..52b9af6
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="An open-source PHP-based bulletin board package"
+HOMEPAGE="https://www.phpbb.com/"
+SRC_URI="https://download.phpbb.com/pub/release/$(ver_cut 1-2)/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+IUSE="ftp gd mssql mysqli postgres sqlite zlib"
+REQUIRED_USE="|| ( mssql mysqli postgres sqlite )"
+
+PHP_RDEPEND="(
+       virtual/httpd-php:@SLOT@
+       dev-lang/php:@SLOT@[ftp?,gd?,json,mssql?,mysqli?,postgres?,sqlite?,xml,zlib?]
+)"
+
+RDEPEND="|| (
+       ${PHP_RDEPEND//@SLOT@/7.2}
+       ${PHP_RDEPEND//@SLOT@/7.1}
+)"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}${PV%%.*}"
+
+src_install() {
+       webapp_src_preinst
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       webapp_configfile  "${MY_HTDOCSDIR}"/config.php
+       webapp_hook_script "${FILESDIR}"/permissions
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+       webapp_src_install
+
+       # phpBB needs docs together with the other files.
+       dosym ../webapps/${PN}/${SLOT}/htdocs/docs /usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+       einfo "phpBB needs a specific web server configuration. For Apache httpd, an"
+       einfo "example configuration is provided via .htaccess files. For lighttpd and"
+       einfo "NGINX, example configuration files can be found in the documentation."
+
+       if use vhosts; then
+               echo
+               ewarn "When installing with webapp-config, specify a group that includes your"
+               ewarn "PHP user with the -g option. It will default to the web server group"
+               ewarn "when running webapp-config as root."
+       fi
+}