media-libs/assimp: patch that fixes Findassimp cmake module path
authorSlawomir Lis <slis@gentoo.org>
Mon, 26 Sep 2016 06:06:28 +0000 (08:06 +0200)
committerSlawomir Lis <slis@gentoo.org>
Mon, 26 Sep 2016 06:06:28 +0000 (08:06 +0200)
In default assimp installation there are hardcoded paths for /usr/local/lib
Reported in bug 595066

Reported-By: Patrick Nicolas <patricknicolas@laposte.net>
Package-Manager: portage-2.3.1

media-libs/assimp/assimp-3.3.1.ebuild
media-libs/assimp/files/findassimp-3.3.1.patch [new file with mode: 0644]

index 02d5f9523e6317fb3f513db78472c5fd65907ab1..823efd807deb80c3ec30c195ba4959b35360109c 100644 (file)
@@ -24,6 +24,11 @@ DEPEND="${RDEPEND}
        test? ( dev-cpp/gtest )
 "
 
+src_prepare() {
+       eapply "${FILESDIR}/findassimp-${PV}.patch"
+       eapply_user
+}
+
 src_configure() {
        mycmakeargs=(
                -DASSIMP_BUILD_SAMPLES=$(usex samples) \
diff --git a/media-libs/assimp/files/findassimp-3.3.1.patch b/media-libs/assimp/files/findassimp-3.3.1.patch
new file mode 100644 (file)
index 0000000..0f36faf
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/cmake-modules/Findassimp.cmake   2016-09-26 07:52:09.719727490 +0200
++++ b/cmake-modules/Findassimp.cmake   2016-09-26 07:52:28.509727838 +0200
+@@ -55,13 +55,13 @@
+       find_path(
+         assimp_INCLUDE_DIRS
+         NAMES postprocess.h scene.h version.h config.h cimport.h
+-        PATHS /usr/local/include/
++        PATHS /usr/include/
+       )
+       find_library(
+         assimp_LIBRARIES
+         NAMES assimp
+-        PATHS /usr/local/lib/
++        PATHS /usr/lib/
+       )
+       if (assimp_INCLUDE_DIRS AND assimp_LIBRARIES)
+@@ -78,4 +78,4 @@
+         endif (assimp_FIND_REQUIRED)
+       endif (assimp_FOUND)
+       
+-endif(WIN32)
+\ Brak znaku nowej linii na końcu pliku
++endif(WIN32)