app-editors/nano: add a live vcs ebuild
authorMike Frysinger <vapier@gentoo.org>
Thu, 24 Sep 2015 21:33:39 +0000 (17:33 -0400)
committerMike Frysinger <vapier@gentoo.org>
Thu, 24 Sep 2015 21:33:42 +0000 (17:33 -0400)
app-editors/nano/nano-2.3.6.ebuild
app-editors/nano/nano-2.4.0.ebuild
app-editors/nano/nano-2.4.1.ebuild
app-editors/nano/nano-2.4.2.ebuild
app-editors/nano/nano-9999.ebuild [new file with mode: 0644]

index bc910efababf91330d37864a466d9acdf47cdc86..8096b33a65169161ff1a531b9fd465545ed2f4e5 100644 (file)
@@ -11,6 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
 else
        MY_P=${PN}-${PV/_}
        SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+       KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="GNU GPL'd Pico clone with more functionality"
@@ -18,7 +19,6 @@ HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="debug justify +magic minimal ncurses nls slang +spell unicode"
 
 RDEPEND=">=sys-libs/ncurses-5.9-r1[unicode?]
@@ -30,6 +30,9 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 src_prepare() {
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       fi
        epatch_user
 }
 
index e0238c111293e33a649818ddb489c63733ea3164..99eb5b1eb2304f3ea1842abb2d5278e53387882e 100644 (file)
@@ -11,6 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
 else
        MY_P=${PN}-${PV/_}
        SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="GNU GPL'd Pico clone with more functionality"
@@ -18,7 +19,6 @@ HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="debug justify +magic minimal ncurses nls slang +spell unicode"
 
 RDEPEND=">=sys-libs/ncurses-5.9-r1[unicode?]
@@ -30,6 +30,9 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 src_prepare() {
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       fi
        epatch "${FILESDIR}"/${P}-no-speller.patch #544296
        epatch_user
 }
index fa4b5d031ce327c487ee2d4c3e4abe03c52b2b39..83741b81ccdc8b4c8c9a3fd9c2428c7679023765 100644 (file)
@@ -11,6 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
 else
        MY_P=${PN}-${PV/_}
        SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="GNU GPL'd Pico clone with more functionality"
@@ -18,7 +19,6 @@ HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="debug justify +magic minimal ncurses nls slang +spell unicode"
 
 RDEPEND=">=sys-libs/ncurses-5.9-r1[unicode?]
@@ -30,6 +30,9 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 src_prepare() {
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       fi
        epatch_user
 }
 
index b18cbc77ad0dd4906902196406a027e8fd2474ef..8548decc2d0ec1bd2a98920101af036be6f88316 100644 (file)
@@ -11,6 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
 else
        MY_P=${PN}-${PV/_}
        SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="GNU GPL'd Pico clone with more functionality"
@@ -18,7 +19,6 @@ HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
 
 LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0[unicode?]
@@ -33,6 +33,9 @@ DEPEND="${RDEPEND}
        static? ( ${LIB_DEPEND} )"
 
 src_prepare() {
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       fi
        epatch_user
 }
 
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
new file mode 100644 (file)
index 0000000..8548dec
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+       ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
+       inherit subversion autotools
+else
+       MY_P=${PN}-${PV/_}
+       SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-guide.xml"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0[unicode?]
+       sys-libs/ncurses:0[static-libs(+)]
+       magic? ( sys-apps/file[static-libs(+)] )
+       nls? ( virtual/libintl )
+       !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )
+       virtual/pkgconfig
+       static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       fi
+       epatch_user
+}
+
+src_configure() {
+       use static && append-ldflags -static
+       eval export ac_cv_{header_magic_h,lib_magic_magic_open}=$(usex magic)
+       local myconf=()
+       case ${CHOST} in
+       *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+       esac
+       econf \
+               --bindir="${EPREFIX}"/bin \
+               --htmldir=/trash \
+               $(use_enable !minimal color) \
+               $(use_enable !minimal multibuffer) \
+               $(use_enable !minimal nanorc) \
+               --disable-wrapping-as-root \
+               $(use_enable spell speller) \
+               $(use_enable justify) \
+               $(use_enable debug) \
+               $(use_enable nls) \
+               $(use_enable unicode utf8) \
+               $(use_enable minimal tiny) \
+               $(usex ncurses --without-slang $(use_with slang)) \
+               "${myconf[@]}"
+}
+
+src_install() {
+       default
+       rm -rf "${D}"/trash
+
+       dodoc doc/nanorc.sample
+       dohtml doc/faq.html
+       insinto /etc
+       newins doc/nanorc.sample nanorc
+       if ! use minimal ; then
+               # Enable colorization by default.
+               sed -i \
+                       -e '/^# include /s:# *::' \
+                       "${ED}"/etc/nanorc || die
+       fi
+
+       dodir /usr/bin
+       dosym /bin/nano /usr/bin/nano
+}