app-text/libpaper: Version bump (v1.1.28)
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 21 Mar 2020 10:47:51 +0000 (13:47 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 21 Mar 2020 10:49:16 +0000 (13:49 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-text/libpaper/Manifest
app-text/libpaper/libpaper-1.1.28.ebuild [new file with mode: 0644]

index 9e26f125fb4829bf8ea0166142968325b7371479..69a68b1fba55853cdbf97583e2f6208b93b4ea31 100644 (file)
@@ -1 +1,2 @@
 DIST libpaper_1.1.24+nmu5.tar.gz 49032 BLAKE2B 27a684dc02d5d25c84a92161e7178d1f369444d50c316e7303579a2f8ede8590d4a19637b7066fcc8909f7942fa965d8421d468b28e99b8e963f4b2b170f2ab3 SHA512 4d20d454dd7d09dd7e84b9ccc3b0ff8d65d95e0ae3874ec41462f812882e7ead032310396801a47a32bfff112c4a9adaf2d8d3e6235a1fa6fbb853196a363c56
+DIST libpaper_1.1.28.tar.gz 42356 BLAKE2B 48c4a28c6ff01bd91e257b6b306e787e5c6112052cff09bdb501d1cc4ddd10964c3588942098a6092d5a44391dfb22e10d5147d4c5012497f473473129ff7422 SHA512 3bf6ebb0af89931d2f72ea4a09a7fa958b2facda5f238983ec7bac39652e08614b33f0de3af74a03457b2a4203eee4950bf18a4b726e79aa64093ace6a1fb0bc
diff --git a/app-text/libpaper/libpaper-1.1.28.ebuild b/app-text/libpaper/libpaper-1.1.28.ebuild
new file mode 100644 (file)
index 0000000..30cbd0b
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="http://packages.debian.org/unstable/source/libpaper"
+SRC_URI="mirror://debian/pool/main/libp/libpaper/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DOCS=( README ChangeLog debian/changelog )
+
+src_prepare() {
+       sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+       eautoreconf
+       default
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}"     econf \
+               --disable-static
+}
+
+multilib_src_install_all() {
+       find "${ED}" -name '*.la' -exec rm -f {} +
+
+       einstalldocs
+
+       dodir /etc
+       (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
+               || die "papersize config failed"
+
+       if ! has_version app-text/libpaper ; then
+               echo
+               elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
+               echo
+       fi
+}