dev-perl/File-NFSLock: Fix for '.' in @INC re bug #615094
authorKent Fredric <kentnl@gentoo.org>
Mon, 26 Jun 2017 07:54:21 +0000 (19:54 +1200)
committerKent Fredric <kentnl@gentoo.org>
Mon, 26 Jun 2017 07:57:00 +0000 (19:57 +1200)
Fix use of 'do q[relativepath]' for 5.26 changes.

Bug: https://bugs.gentoo.org/615094
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/File-NFSLock/File-NFSLock-1.270.0.ebuild
dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch [new file with mode: 0644]

index dcdb074d3fcc8643703176fb58ad8c3331a99a4b..6496e7a37fb1c3cf37343dfbbc9f82f55164d87a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -14,5 +14,5 @@ KEYWORDS="amd64 x86"
 IUSE=""
 
 DEPEND="virtual/perl-ExtUtils-MakeMaker"
-
+PATCHES=( "${FILESDIR}/${PN}"-1.27-no-dot-inc.patch )
 SRC_TEST="do"
diff --git a/dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch b/dev-perl/File-NFSLock/files/File-NFSLock-1.27-no-dot-inc.patch
new file mode 100644 (file)
index 0000000..9b67d24
--- /dev/null
@@ -0,0 +1,34 @@
+From 08deb6590eecd9d92a38edf1b22d615175e1d8d3 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Mon, 26 Jun 2017 19:43:14 +1200
+Subject: [PATCH] Fix for '.' removal from Perl 5.26 @INC
+
+---
+ File-NFSLock.spec.PL | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/File-NFSLock.spec.PL b/File-NFSLock.spec.PL
+index fdf9fdf..f5586c1 100644
+--- a/File-NFSLock.spec.PL
++++ b/File-NFSLock.spec.PL
+@@ -18,7 +18,7 @@ sub WriteMakefile {
+   } elsif (my $version_from = $props{VERSION_FROM}) {
+     $@ = "";
+     $version = eval qq{
+-      do "$version_from";
++      do "./$version_from";
+       \$$name\::VERSION || die "$version_from: Missing VERSION";
+     };
+     die $@ if $@;
+@@ -29,7 +29,7 @@ sub WriteMakefile {
+     die "Makefile.PL: Could not determine version!";
+   }
+ }
+-do "Makefile.PL";
++do "./Makefile.PL";
+ if ($name) {
+   $name =~ s/::/-/g;
+ } else {
+-- 
+2.13.1
+