www-client/firefox: disable ELF hack
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 30 Jan 2019 15:03:05 +0000 (16:03 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 30 Jan 2019 15:03:21 +0000 (16:03 +0100)
Closes: https://bugs.gentoo.org/676908
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-65.0.ebuild

index 157df868264ce9bf8ea82a0042a59afd638ac7f2..556ea09a80ea8803bdaf2eff454e54a5dc317552 100644 (file)
@@ -462,11 +462,9 @@ src_configure() {
        # disable webrtc for now, bug 667642
        use arm && mozconfig_annotate 'broken on arm' --disable-webrtc
 
-       if use clang ; then
-               # https://bugzilla.mozilla.org/show_bug.cgi?id=1423822
-               # bug #669382
-               mozconfig_annotate 'elf-hack is broken when using Clang' --disable-elf-hack
-       fi
+       # https://bugzilla.mozilla.org/show_bug.cgi?id=1423822
+       # bug #669382 #676908
+       mozconfig_annotate 'elf-hack is broken' --disable-elf-hack
 
        echo "mk_add_options MOZ_OBJDIR=${BUILD_OBJ_DIR}" >> "${S}"/.mozconfig
        echo "mk_add_options XARGS=/usr/bin/xargs" >> "${S}"/.mozconfig