media-sound/din: bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Tue, 17 Dec 2019 17:00:15 +0000 (18:00 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Tue, 17 Dec 2019 17:01:04 +0000 (18:01 +0100)
1) eapi7
2) updated and organized deps
3) introduced alsa and jack use flags
4) updated relevant patches

based on ebuild update by Samuel Bauer <samuel.bauer@yahoo.fr>

Closes: https://bugs.gentoo.org/699358
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/din/Manifest
media-sound/din/din-43.0.1.ebuild [new file with mode: 0644]
media-sound/din/files/din-43.0.1-fix-random-constants.patch [new file with mode: 0644]
media-sound/din/files/din-43.0.1-makefile.patch [new file with mode: 0644]

index df912614e3d83433ec00f77d11111f9655e12ecf..a31e79724f207896aa965d5dd153f4931683215b 100644 (file)
@@ -1 +1,2 @@
+DIST din-43.0.1.tar.gz 3644254 BLAKE2B 6b441ce93b3bd68e3bad5d7a6fea1914f250a5e35410f12c64da7ab1f530aa74b4a8f624a7b6ec70e26b62f5b3f8ada674ad7286b89e2569bbec9f3f29cccac6 SHA512 14df7f52a80801f062ed1a81c5625d8730e7bcc21cfa5256ecce9b478494828a3d0877c37434f30883aa519f767a70ba1cee4d203ec57c5bc72de1c47d2d848d
 DIST din-5.2.1.tar.gz 321269 BLAKE2B eb3b3ebad7a973dfc9bd4d6edbcc83e545c5e11c564a4f592ddef996e971c52fd8b4508933d76dd6964fcbaf5eebe5f0230171eef6466d63540c01918a946379 SHA512 0fa7de383c869f9f55ee055f821f3b541ca7df83d61f9bdb6b9e0227a724abe098073985cb4f3eb381199d4baa84d9ee2b86b74614e11cb8b58b119230ca3c09
diff --git a/media-sound/din/din-43.0.1.ebuild b/media-sound/din/din-43.0.1.ebuild
new file mode 100644 (file)
index 0000000..891e798
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="a software musical instrument and audio synthesizer"
+HOMEPAGE="http://dinisnoise.org/"
+SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack"
+
+BDEPEND="
+       app-text/dos2unix
+       virtual/pkgconfig
+"
+CDEPEND="dev-lang/tcl:0=
+       media-libs/libsdl:=
+       virtual/opengl
+       alsa? ( media-libs/alsa-lib )
+       jack? ( virtual/jack )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="
+       ${RDEPEND}
+       dev-libs/boost
+"
+REQUIRED_USE="|| ( alsa jack )"
+
+PATCHES=(
+       "${FILESDIR}/${P}-makefile.patch"
+       "${FILESDIR}/${P}-fix-random-constants.patch"
+)
+
+src_prepare() {
+       default
+
+       dos2unix pixmaps/${PN}.desktop || die "Failed to fix desktop file"
+
+       use jack && sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking"
+
+       eautoreconf
+}
+
+src_configure() {
+       # Jack takes over alsa.
+       local sound_engine
+
+       use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
+
+       econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
+}
diff --git a/media-sound/din/files/din-43.0.1-fix-random-constants.patch b/media-sound/din/files/din-43.0.1-fix-random-constants.patch
new file mode 100644 (file)
index 0000000..29f75d3
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/include/random.h b/include/random.h
+index 99d79fb..91ed250 100644
+--- a/include/random.h
++++ b/include/random.h
+@@ -16,8 +16,8 @@
+ const int N = 624;\r
+ const int M = 397;\r
+ const unsigned int MATRIX_A = 0x9908b0df; /* constant vector a */\r
+-const int UPPER_MASK = 0x80000000; /* most significant w-r bits */\r
+-const int LOWER_MASK = 0x7fffffff; /* least significant r bits */\r
++const unsigned int UPPER_MASK = 0x80000000; /* most significant w-r bits */\r
++const unsigned int LOWER_MASK = 0x7fffffff; /* least significant r bits */\r
\r
+ static unsigned int mt[N]; /* the array for the state vector  */\r
+ static int mti=N+1; /* mti==N+1 means mt[N] is not initialized */\r
diff --git a/media-sound/din/files/din-43.0.1-makefile.patch b/media-sound/din/files/din-43.0.1-makefile.patch
new file mode 100644 (file)
index 0000000..f3a8116
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index bcbd601..12ca52b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,5 +1,5 @@
+-AM_CXXFLAGS = -I ../include -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -DPREFIX=\"@prefix@\"
+-LIBS +=  -ltcl8.6 -lSDL -lGL -lpthread -lasound
++AM_CXXFLAGS = -I ../include -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -DPREFIX=\"@prefix@\"
++LIBS +=  -ltcl -lSDL -lGL -lpthread -lasound
+ AM_CFLAGS = -I ../include
+ bin_PROGRAMS = din