dev-python/python-gnupg: bump to version 0.4.5
authorConrad Kostecki <conikost@gentoo.org>
Tue, 17 Dec 2019 18:33:41 +0000 (19:33 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Tue, 17 Dec 2019 18:37:28 +0000 (19:37 +0100)
Dropped patches, since they got merged.
Also added python3.8 support, as all tests locally passed.

Bug: https://bugs.gentoo.org/685864
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
dev-python/python-gnupg/Manifest
dev-python/python-gnupg/python-gnupg-0.4.5.ebuild [new file with mode: 0644]

index e53311398bf723f195f54b8d4679ae379cfdec9e..59abc83a1f6f4be9f1c99c83956259b9fb48bf26 100644 (file)
@@ -1,3 +1,4 @@
 DIST python-gnupg-0.4.0.tar.gz 43987 BLAKE2B 59e72f894c5d554ba2a7c348ad3625500798ad6ac18332a3bb668b42559f52b58e3cd0f8b79ef1a99f37e796b48169d0bf36414e938e9039784cede4303cbb03 SHA512 f486ec97aee01cf46d055421211ff5704093a382155043b7ced6f809dc15d7669d5869038a1b26c5f1831076d85c929d781bc22e35ab293a14bc6e2f5f27fa32
 DIST python-gnupg-0.4.1.tar.gz 44534 BLAKE2B 0b58312b9f094b29f7009bb7a44ea3607be826ae2fda958dae0ba9dd5a2d7f81843fe23a6fe336b9df85c059e5b114787dab372df42b14b83cb73fb02abee919 SHA512 0920a1de4d98a745f7747280672975db04c40b59ea4436745cdbefa86a0c88bfdc086d6dd312c82a0a9e9f8cafb5651f8e17d86e0ee37282b5fc36e7ac8d1a1e
 DIST python-gnupg-0.4.3.tar.gz 46958 BLAKE2B c83b13f8b36c136ac75e8a69dccb07025be3397284e27d9624677cd76ac8527bed67644be7a00958fdb248772a0c37de09257fb711eb16a2c982dbca0368dbd6 SHA512 9381acb1246b6ceec4de21091f2ce57dba9c6600dfb52ddee181effbd2e749d18935e6b6bb2183816064e9129cd1bb3ebfdd28a5dcddc9be1c56261a501067d8
+DIST python-gnupg-0.4.5.tar.gz 48792 BLAKE2B 1bf9cc1c8efafd4fa783574724852d0f168d4d4d4ec188bade9a3ff21be61cc1b087bd4ae72f11f189d182cd49c765d9b57ef22d954a69555c0368f1d863f1fd SHA512 441b49e1f87a7e8e3abf2d6e90f677dc33f1b66a36483787f972378127f31308bacc5e200ae254dd75942191d2fabd61ca5a2f200cf5400be70957942f889ca4
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.5.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.5.ebuild
new file mode 100644 (file)
index 0000000..de7b685
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="no"
+PYTHON_COMPAT=( pypy{,3} python2_7 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for GnuPG"
+HOMEPAGE="
+       https://bitbucket.org/vinay.sajip/python-gnupg
+       https://pypi.org/project/python-gnupg/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+python_test() {
+       # NO_EXTERNAL_TESTS must be enabled,
+       # to disable all tests, which need internet access.
+       NO_EXTERNAL_TESTS=1 "${PYTHON}" test_gnupg.py || die "Tests failed with ${EPYTHON}"
+}