build-sys: avoid harmless error message during install
authorFabian Groffen <grobian@gentoo.org>
Fri, 27 Apr 2012 15:52:08 +0000 (17:52 +0200)
committerFabian Groffen <grobian@gentoo.org>
Fri, 27 Apr 2012 15:52:08 +0000 (17:52 +0200)
Different way to fix #411817 by just avoiding to list a directory that
won't contain python files.

pym/Makefile.in

index aa903bb42b75cb4d491220f4f6b1733f82bdf86e..ce8fa39206fedaba03e7ca29ff9b304977853838 100644 (file)
@@ -17,7 +17,7 @@ INSTALL = @INSTALL@
 INSTALL_subst = ${top_builddir}/subst-install
 
 list_sourcedir_dirs = \
-       ( cd "$(srcdir)" && find . -name '.svn' -prune -o -type d -print )
+       ( cd "$(srcdir)" && find . -name '.git' -prune -o -type d -print | sed 's#^./\?##' )
 
 all: