app-emulation/punes: version bump to 0.104
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>
Mon, 13 May 2019 23:16:30 +0000 (02:16 +0300)
committerMichael Palimaka <kensington@gentoo.org>
Wed, 15 May 2019 10:48:35 +0000 (20:48 +1000)
Closes: https://github.com/gentoo/gentoo/pull/11989
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
app-emulation/punes/Manifest
app-emulation/punes/punes-0.104.ebuild [new file with mode: 0644]

index 8dc1779acd5bbb5e024bb3e3fc5c2a01dfb1883c..d5ec7d88c2838ed70c6d90bed44997179be88fb4 100644 (file)
@@ -1 +1,2 @@
 DIST punes-0.103.tar.gz 5366838 BLAKE2B cb4a9a1336293891e06d573f68c52962e79220e7024fad716a957f5423a72703a34efc3fb6129dbe9ffde2c96fe7abd2a1ad4a622aaca89e90f6a2d5af8c1a53 SHA512 db0fbc075b9fd46be8013b17c03fd7abd12b209ce166557c83283c917e53224712ba5838cd8b9e7fad3d21271f29e475460996dd9800b9f759602e289bad4205
+DIST punes-0.104.tar.gz 5381182 BLAKE2B fefa6eb85e9cfe5eb10fd987061e6f708a2d29db374552ca217e1e47bfd3a982390d2fdf33f23407bb54d7e1a3491e33cc2c520ff3ead4566f687c6c652bcc6a SHA512 9636440cf66cb9f48b532cebff4342a775ddacffd98748e5669d820e213a648cbfb3e4e94f67389f21f88b4fa618bf514e31738c10df079abe22d4b19593d904
diff --git a/app-emulation/punes/punes-0.104.ebuild b/app-emulation/punes/punes-0.104.ebuild
new file mode 100644 (file)
index 0000000..ae456a0
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg-utils
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cg"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5
+       cg? ( media-gfx/nvidia-cg-toolkit )
+       media-libs/alsa-lib
+       virtual/opengl"
+
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig"
+
+S="${WORKDIR}/puNES-${PV}"
+
+src_prepare() {
+       default
+
+       sed -i "/update-desktop-database/d" misc/Makefile.am || die
+       eautoreconf
+       # FIXME why eautoreconf can't handle this?
+       cd "src/extra/lib7zip-1.6.5" || die
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_with cg opengl-nvidia-cg)
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}