dev-perl/Net-SSH2: Add build fix for Perl 5.26, bug 623008
authorAndreas K. Huettel <dilfridge@gentoo.org>
Wed, 5 Jul 2017 16:58:22 +0000 (18:58 +0200)
committerAndreas K. Huettel <dilfridge@gentoo.org>
Wed, 5 Jul 2017 16:58:22 +0000 (18:58 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/Net-SSH2/Net-SSH2-0.580.0-r1.ebuild

index fec5846c8a6568b0044df9b278e1e3d2d0a042de..f9768f58738fbbbb67f4227816356748f4701609 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -30,6 +30,12 @@ DEPEND="${RDEPEND}
        >=virtual/perl-ExtUtils-MakeMaker-6.50
 "
 
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}
+
 src_configure() {
        use gcrypt && myconf=gcrypt
        perl-module_src_configure